pyOpenSSL Version 0.11 disappeared in PyPI?

Asked by nobbkl on 2013-06-06

I tried to install pyOpenSSL, Version 0.11 using pip, but it throw an error:
"DistributionNotFound: No distributions matching the version for pyOpenSSL==0.11"

When I checked PyPI, I realized that there are indeed no files for Version 0.11:
https://pypi.python.org/pypi/pyOpenSSL/0.11
Did they get deleted or did I oversee something?

Thanks for your help!

Best Regards,
Norbert

Question information

Language:
English Edit question
Status:
Solved
For:
pyOpenSSL Edit question
Assignee:
No assignee Edit question
Solved by:
Jean-Paul Calderone
Solved:
2013-06-06
Last query:
2013-06-06
Last reply:
2013-06-06
Best Jean-Paul Calderone (exarkun) said : #1

I think the cause is that recently PyPI started encouraging projects to change their configuration to not link to external downloads. I changed this configuration for the pyOpenSSL project on PyPI a few days ago. As a result, the downloads hosted on Launchpad are no longer discovered by pip.

I just re-added a link to the 0.11 .tar.gz release. I think this will help let pip install that version. I did not re-add links to any of the other release package types. Let me know if one of the other types would be more useful than the .tar.gz.

Sorry about the difficulties.

nobbkl (nobbikl) said : #2

Thank you for your fast answer!

nobbkl (nobbikl) said : #3

Thanks Jean-Paul Calderone, that solved my question.