problem with revision 36 with dc1394_new

Asked by arjmage on 2010-11-25

Hi,

Firstly, I want to write in my thanks for developing this super library for python! I obtained a branch from Tamas before this project found its way onto launchpad, and used it for my research work. It worked great, and I'm happy to report that a few months ago I ran the (first ever?) working copy of pydc1394 underwater! Leading on from that, I've decided to take the development forward.

I just bzr branched the revision 36 from launchpad, and installed it into my development machine. The run_tests.py failed, as also did trying to import the library in python.

On running "import pydc1394", I received the following stack trace:

>>> import pydc1394
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python2.6/dist-packages/pydc1394/__init__.py", line 23, in <module>
    from camera import Camera, DC1394Library, SynchronizedCams
  File "/usr/local/lib/python2.6/dist-packages/pydc1394/camera.py", line 24, in <module>
    from _dc1394core import *
  File "/usr/local/lib/python2.6/dist-packages/pydc1394/_dc1394core.py", line 692, in <module>
    _dll.dc1394_new.argtypes = None
  File "/usr/lib/python2.6/ctypes/__init__.py", line 366, in __getattr__
    func = self.__getitem__(name)
  File "/usr/lib/python2.6/ctypes/__init__.py", line 371, in __getitem__
    func = self._FuncPtr((name_or_ordinal, self))
AttributeError: python: undefined symbol: dc1394_new

Has something fundamental changed? What should I do to get this super library working again?

Any help will be much appreciated.

Cheers,
Arjun

Question information

Language:
English Edit question
Status:
Answered
For:
pyDC1394 Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-25
Last reply:
2010-11-26
SirVer (sirver) said : #1

I replied on your question on the google group.

Can you help with this problem?

Provide an answer of your own, or ask arjmage for more information if necessary.

To post a message you must log in.