pulseaudio volume swells

Asked by piratemurray

I'm experiencing issues with pulseaudio whereby randomly the volume swells up and down. I think this has something to with pulseaudio trying to normalize the volume in real time and getting it wrong.

On karmic I removed pulseaudio and it solved my problems. I have now upgraded to (with a clean install) lucid alpha-1 and I would like to keep pulseaudio but I can't abide this volume swelling issue.

My question is whether my assumption about the normalization is correct and how I can turn it off or improve the way it works.

I hear this problem whilst playing mp3s, watching videos and playing flash content. I can't use pulseaudio on QuakeLive either without the game performance taking a massive hit.

My system set up is AMD64 lucid alpha-1, SoundBlaster Audigy 2 ZS.

Question information

English Edit question
PulseAudio Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
David Henningsson (diwic) said :

It is the first time I hear about "volume swelling", and Lucid alpha-1 should ship with flat-volumes/auto-gain-control disabled by default. Will it help if you try what is written here? https://wiki.ubuntu.com/DebuggingSoundProblems/KarmicCaveats#Volume%20range%20anomalies

Revision history for this message
piratemurray (mez-pahlan) said :

I think this may have helped, thanks. I tried the first solution which was to change a line in /etc/pulse/default.pa

load-module module-udev-detect ignore_dB=1

So far so good. Obviously I'll have to keep checking if this truly did solve the problem.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
piratemurray (mez-pahlan) said :

Today's update of Lucid Lynx causes this problem again.

Something is not right with pulseaudio and audigy 2 ZS.

It is as if someone is turning the volume up and down randomly. This is a bug right? Can I create a report so it can be fixed?

Revision history for this message
Kai Krakow (hurikhan77) said :

I'm having the same issue in Gentoo Linux. Originally I thought it has something to do with the emu10k driver of my Soundblaster card. I removed it from the system and used the onboard AC97. It worked for a while, but this annoying problem came back. I ignored this problem as I wasn't using that system so much anyways. Now I bought a new system, reinstalled everything from scratch, using the onboard HDAudio solution. It worked fine for some weeks and I thought: "finally, solved, maybe an issue with the sound driver after all"...

But well: The problem returned. Since a few days, probably related to an upgrade of the kernel and some other packages, the problem returned. So after all it may be unrelated to hardware or drivers and pulseaudio maybe does something really dumb. I don't think the in-kernel driver for sound changed so dramatically.

It is really difficult to find people who are a victim of this behaviour. Did anyone find a solution?

Revision history for this message
AaronELBorg (elmastero74) said :

I got it too on a POS Dell Latitude running lubuntu 14.04 with the kxstudio PPAs. Pretty annoying. I tried the fix in #2.

Is it supposed to look like this?

.ifexists module-udev-detect.so
load-module module-udev-detect

is now:
.ifexists module-udev-detect.so
load-module module-udev-detect ignore_dB=1

I still hear it though.

Revision history for this message
jhony singh (harei535) said :

I am here to just take some guidance about it because facing the similar type of issue while developing my new gamming project you can see here https://bestgamesapk.com/moviebox-pro/ but still not able to solve it.

Can you help with this problem?

Provide an answer of your own, or ask piratemurray for more information if necessary.

To post a message you must log in.