Trunk 297 does not support video

Asked by Peter

Dear Psiphon developers,
I installed the Psiphon 2.6 trunk 297. Video is not available. It could play video very well last year when I tried it.

Please advice.

Question information

Language:
English Edit question
Status:
Answered
For:
psiphon Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Adam Kruger (adam-kruger) said :
#1

Please check your JSF table. The only way video will work is with JavaScript filter exclusions/replacements. From which sites would you like to watch videos through Psiphon?

Revision history for this message
Peter (peterpn) said :
#2

Hello Adam,
I have checked the new trunk record. It said that youtube video had been fixed.

Now, I want to update the running psiphon software from 2.6.297 to 2.6.317. How do I do this? How do I keep the psiphon mysql database intact?

I don't want to erase the whole software and reinstall again.

Thanks.

Revision history for this message
e.fryntov (e-fryntov) said :
#3

Hi Peter,

I checked revisions diff between 297 and current trunk. Unfortunately there are changes that impacted not only certain SQL scripts but also the server config and some php scripts as well.

Although we do have an upgrade procedure, it is tailored to our needs since we run production nodes on FreeBSD and will not work in your environment.

One approach you can take is to comment out some DB init code from trunk/tools/db_install.sh and run full installation. You'll have to comment out the following lines like below:

#echo "Creating 'psiphon' database and 'psiphon' mysql user"
#cat sql/create_db.sql sql/grant.new.sql | mysql -uroot ${pass_string}

#echo "Creating initial baseline database schema"
#cat sql/structure.2.3.sql | mysql -uroot ${pass_string} psiphon

#echo "Creating 'db_schema_version' table"
#cat sql/db_schema_version.sql | mysql -uroot ${pass_string} psiphon

#echo "Creating default 'admin' user"
#cat sql/init.sql | mysql -uroot ${pass_string} psiphon

This should leave your data intact and only update JS rules and perform outstanding SQL upgrades.

IMPORTANT: Make sure you are using the same install directory and providing the same mysql password as your current installation. In case you don't remember the password you can find it in your current <Psiphon install directory>/www/config.php in the $config[db_pass] variable. Creating a backup of the current psiphon database and psiphon install directory is also highly recommended.

Revision history for this message
Peter (peterpn) said :
#4

Dear Fryntov,
Thanks for the method proposed.

May I make a further suggestion.

Since Psiphon 2.6 or up will remain as one of the primary circumvention software, keeping it updated on-the-fly is very important. Why is it important? Because most public video sites (like youtube etc.) change their site scripts often. If Psiphon 2.6 is not updated according to these changes, Psiphon 2.6 users will not be able to view video. Effort made on developing Psiphon 2.6 will become meaningless. Psiphon 2.6 can just work like Psiphon 1.6.

If someone can develope a fast patch update procedure for Psiphon 2.6, it will be a great contribution. Every time when those public video sites (like youtube etc.) change their site scripts, developers can suggest and post their solution on here. If an update procedure is available, Psiphone 2.6 can be updated on-the-fly immediately.

It is only my personal idea. I don't know whether it can be done easily or not.

Revision history for this message
sai krishna (gadgetssai) said :
#7

Can you help with this problem?

Provide an answer of your own, or ask Peter for more information if necessary.

To post a message you must log in.