Utility to display its environment.

having a problem compiling code under Ubuntu 12.04

Asked by roger sibert on 2012-11-25

Using Jenkins build sever for the output but see much of the same thing when running everything by hand from the command prompt.

What I was trying to figure is what version of build software procenv is designed for/built against. Im not great at chasing this sort of thing but its looking like either a version problem at that point a build environment on my end.

Thanks,
Roger

+ ./reconf
aclocal: aclocal: file `m4/lt~obsolete.m4' does not exist
configure.ac:18: error: possibly undefined macro: AM_PROG_CC_C_O
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:44: error: possibly undefined macro: AM_CONDITIONAL
configure.ac:51: error: possibly undefined macro: AM_INIT_AUTOMAKE

configure.ac: no proper invocation of AM_INIT_AUTOMAKE was found.
configure.ac: You should verify that configure.ac invokes AM_INIT_AUTOMAKE,
configure.ac: that aclocal.m4 is present in the top-level directory,
configure.ac: and that aclocal.m4 was recently regenerated (using aclocal).
configure.ac:17: installing `config/install-sh'
src/Makefile.am:6: HAVE_SELINUX does not appear in AM_CONDITIONAL
src/Makefile.am:9: HAVE_APPARMOR does not appear in AM_CONDITIONAL
src/Makefile.am:2: compiling `procenv.c' with per-target flags requires `AM_PROG_CC_C_O' in `configure.ac'
src/Makefile.am: installing `config/depcomp'
/usr/share/automake-1.11/am/depend2.am: am__fastdepCC does not appear in AM_CONDITIONAL
/usr/share/automake-1.11/am/depend2.am: The usual way to define `am__fastdepCC' is to add `AC_PROG_CC'
/usr/share/automake-1.11/am/depend2.am: to `configure.ac' and run `aclocal' and `autoconf' again.
/usr/share/automake-1.11/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake-1.11/am/depend2.am: The usual way to define `AMDEP' is to add one of the compiler tests
/usr/share/automake-1.11/am/depend2.am: AC_PROG_CC, AC_PROG_CXX, AC_PROG_CXX, AC_PROG_OBJC,
/usr/share/automake-1.11/am/depend2.am: AM_PROG_AS, AM_PROG_GCJ, AM_PROG_UPC
/usr/share/automake-1.11/am/depend2.am: to `configure.ac' and run `aclocal' and `autoconf' again.

Question information

Language:
English Edit question
Status:
Solved
For:
procenv Edit question
Assignee:
No assignee Edit question
Solved by:
James Hunt
Solved:
2012-11-28
Last query:
2012-11-28
Last reply:
2012-11-28
Best James Hunt (jamesodhunt) said : #1

'reconf' isn't included in the distribution. The easiest way to build it is to download an official release, for example https://launchpad.net/procenv/trunk/v0.14/+download/procenv-0.14.tar.gz.

Then, do the following:

tar xvfz procenv-0.14.tar.gz
cd procenv-0.14
./configure && make && sudo make install

If you have checked out the bzr branch, I'd just call 'autoreconf -fi' from the top-level directory before following the process above.

roger sibert (roger-sibert) said : #2

The setup was for a Jenkins CI server specifically to use the bzr branch in case there was something beyond release that was needed.

The build options used for Jenkins job look like this

autoreconf -fi
./reconf
./configure
make

Adding in the autoreconf -fi took care of the build problem

roger sibert (roger-sibert) said : #3

Thanks James Hunt, that solved my question.