PPA for Oneiric?

Asked by Stephen Rees-Carter on 2011-08-11

Would it be possible for you guys to provide support for Oneiric within the PPA?
I've upgraded to Oneiric, but I am really missing Popper.

Question information

Language:
English Edit question
Status:
Solved
For:
Popper Edit question
Assignee:
No assignee Edit question
Solved by:
Ralf Hersel
Solved:
2011-08-20
Last query:
2011-08-20
Last reply:
2011-08-18
Ralf Hersel (ralf.hersel) said : #1

We will create a PPA for Oneiric but not before Ubuntu 11.10 is released. Can you try to install Popper under Oneiric Alpha and tell us if it works in general. This would be a great help for us.

Stephen Rees-Carter (valorin) said : #2

I'd love to try it on Oneiric, but the latest version under the "Downloads" header on the Popper page gives me the Readme telling me to use the PPA... (hence this question)

Where can I download the latest x64 deb and I'll test it for you? :)

Best Ralf Hersel (ralf.hersel) said : #3

1. Goto: https://launchpad.net/~ralf.hersel/+archive/rhersel-ppa
2. Click on: View package details
3. Expand: popper - 0.29.2-0ubuntu1
4. Right-click on: popper_0.29.2-0ubuntu1_all.deb
5. Click on: Save link as ... Save
6. Open your Download folder in Nautilus and right-click: Open with Ubuntu Software Center
7. Install Popper in Software Center
8. Since no starters are installed, you have to start it manually
8.1 In a Terminal goto: /usr/share/popper and run: ./popper_config.py
8.2 In a Terminal goto: /usr/share/popper and run: python popper.py
9. Check the output in the Terminal for error messages from Popper

Stephen Rees-Carter (valorin) said : #4

Great, that works :)

The only errors that appear are:

(popper.py:21021): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
(popper.py:21021): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
(popper.py:21021): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
(popper.py:21021): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

But I keep seeing the same sorts of warnings for other programs, so I assume this is a Oneiric thing?

It appears to be working really well so far. I'll keep using it, and let you know if I experience any issues with it :)

Pa_trick17 (trick17) said : #5

For documetation purposes ;-) :

It's also possible to add the PPA like described and try to "persuade" your unsupported Ubuntu-Distro to install latest Popper Version by editing your PPA entry (f.e. Software Center -> Edit -> Software Sources... -> Other Software -> choose "[...]ralf.hersel/rhersel-ppa[...]" -> Edit...) and change "Distribution" to a supported one (maverick and natty at the moment because these are the distros we are using). It's not less complicated than the way described by Ralf but has the "PPA-convenience" of automatic updates.

Please consider that you are "persuading" an unsupported Distro and please give back by reporting how it works like Stephen does (thanks for that).

Cheers,

Patrick

Stephen Rees-Carter (valorin) said : #6

Thanks Ralf Hersel, that solved my question.

Stephen Rees-Carter (valorin) said : #7

Mmm... that last comment was caused by clicking a button.

Patrick, thanks for the suggestion. I might do that, so I don't have to worry about checking for new version.