Keyring is locked

Asked by Tim Goodwin on 2010-12-16

On system start up - I get the popup from Popper that the keyring is locked. Although I did not set up a keyring password, I need to input my superuser password in order for Popper to work. Is there anyway of bypassing the keyring so that Popper will automatically start without a password?

Question information

Language:
English Edit question
Status:
Solved
For:
Popper Edit question
Assignee:
No assignee Edit question
Solved by:
Theodotos Andreou
Solved:
2010-12-16
Last query:
2010-12-16
Last reply:
2010-12-16
Best Theodotos Andreou (theodotos) said : #1

1) From System --> Preferences --> Startup Applications uncheck the "Secret Storage Service" and "SSH Key Agent"
2) From Terminal type (Assuming you don't need any other keyrings):
    rm -i .gnome/keyrings/*
3) Logout and login back again.
4) Start popper and leave empty password.
5) select the "unsecure" option when asked.

Tim Goodwin (goodwin-my5w) said : #2

OK - seems to work but that should be rm -i .gnome2/keyrings/* and I was not asked for a password or unsecure storage when I logged back. I had to manually re-enter my passwords into Popper configurator and Gwibber. Thanks for your help - I will monitor the situation and let you know if things go awry!