Popper Email Notifier not showing up in Messages Indicator

Asked by Xahrepap on 2010-12-10

Using Maverick 64bit

I downloaded Popper Email Notifie. Installed it from the v023 deb.
https://launchpad.net/popper

I configured it, and the TEST tab shows I configured everything properly. I can't get Popper to appear in the notification menu. I have restarted gnome-pannel, restarted my computer, reinstalled the app, and run a test script that adds a test in the Indicator to show that my Indicator Applet is still letting me add items to the panel. No luck. I checked the /usr/share/indicators/messages/applications/ folder, and there's only the defaults there.

Anyone know how to fix this? Even if someone knows what file I can drop into that folder to make it work that'd be great.

More information: http://askubuntu.com/questions/16770/popper-email-notifier-not-working/16775#16775

Thanks for the help! I look forward to using Email Popper.

Question information

Language:
English Edit question
Status:
Solved
For:
Popper Edit question
Assignee:
Ralf Hersel Edit question
Solved by:
Ralf Hersel
Solved:
2010-12-13
Last query:
2010-12-13
Last reply:
2010-12-13
Ralf Hersel (ralf.hersel) said : #1

Can you please check Popper's log file: /home/user/.popper/popper.log

Xahrepap (johnson-joel-86) said : #2

checking email accounts at: Sun Dec 12 17:59:07 2010
 Write new email
 Open address book
Traceback (most recent call last):
  File "popper.py", line 958, in <module>
    if __name__ == '__main__': main()
  File "popper.py", line 948, in main
    indicator.timeout() # immediate check, firstcheck=True
  File "popper.py", line 454, in timeout
    self.mail_list = get_mail(self.sort_order) # get all mails from all inboxes
  File "popper.py", line 217, in get_mail
    typ, data = srv.search(None, 'UNSEEN') # ALL or UNSEEN
  File "/usr/lib/python2.6/imaplib.py", line 620, in search
    typ, dat = self._simple_command(name, *criteria)
  File "/usr/lib/python2.6/imaplib.py", line 1060, in _simple_command
    return self._command_complete(name, self._command(name, *args))
  File "/usr/lib/python2.6/imaplib.py", line 818, in _command
    ', '.join(Commands[name])))
imaplib.error: command SEARCH illegal in state AUTH, only allowed in states SELECTED

Xahrepap (johnson-joel-86) said : #3

Also, config log file is empty.

Best Ralf Hersel (ralf.hersel) said : #4

Yes, this is a known bug which I don't know how to solve. See https://bugs.launchpad.net/popper/+bug/648930 for more details. Try to remove all folder entries in Popper Configurator. Sorry

Xahrepap (johnson-joel-86) said : #5

Thanks Ralf Hersel, that solved my question.

Xahrepap (johnson-joel-86) said : #6

That worked. Just don't get to have other folders now :( Oh well. Popper is still really nice to have. Thanks for the help.

Ralf Hersel (ralf.hersel) said : #7

Ok, you may test a little bit with different folder settings for your IMAP account. I did it for my Gmail test account and couldn't find any problems. Maybe it works with other folder entries. This would help us to find a pattern for this problem. Thanks, Ralf

Xahrepap (johnson-joel-86) said : #8

It actually just might be spaces.
Before I was doing this:
"INBOX, OTHERFOLDER, SOMEFOLDER"
I just tried the same thing but without spaces and it worked.
"INBOX,OTHERFOLDER,SOMEFOLDER"

I'll keep playing around and let you know if I find anything different

I've had the same problem.
Reinstalled popper 0.24 and configure it, and start to work!