hwinfo module

Asked by Jon Winskill on 2011-03-27

Not sure if this is a bug, or user error, so I figured I would ask a question since it is probably user error.
I installed plymouth-manager 1.3.2-1 from the ppa repository on Ubuntu 10.4, but when I run it I get the following error:

Traceback (most recent call last):
  File "plymouth-manager.py", line 23, in <module>
    main.PlymouthManager()
  File "/usr/share/plymouth-manager/src/main.py", line 135, in __init__
    if value == funcmain.getCurrentRes():
  File "/usr/share/plymouth-manager/src/funcmain.py", line 34, in getCurrentRes
    tmpBuf = open("/etc/default/" + hwinfo.getBoot(), "r")
IOError: [Errno 2] No such file or directory: '/etc/default/error'

It looks like you're importing a module called hwinfo, which is missing on my system. Simple enough. However, I can't find any mention of this module in the python package index (pypi.python.org/pypi), or through any web searches. I installed a package called hwinfo through synaptic, but this doesn't appear to be a python module. Any idea where I can get hwinfo? I also tried installing 1.4.0 (as the 1.4.1 build was broken) from sourceforge, but that still appears to use hwinfo.

Question information

Language:
English Edit question
Status:
Answered
For:
Plymouth Manager Edit question
Assignee:
No assignee Edit question
Last query:
2011-03-27
Last reply:
2012-07-06
Mario Guerriero (mefrio-g) said : #1

try to install the latest version. If it doesn't work I will send you the module hwinfo.

Jon Winskill (jonwinskill) said : #2

Thanks. I just tried 1.4.2, but it gives me the same problem. Please send me the module when you get a chance.

hola171@tiscali.it (hola171) said : #3

I tried plymouth-manager_1.5.0-1_all.deb and the problem is

Traceback (most recent call last):
  File "plymouth-manager.py", line 23, in <module>
    main.PlymouthManager()
  File "/usr/share/plymouth-manager/src/main.py", line 178, in __init__
    self.getCurrentTheme()
  File "/usr/share/plymouth-manager/src/main.py", line 209, in getCurrentTheme
    self.Theme = self.fileTheme.get("Plymouth Theme", "Name")
  File "/usr/lib/python2.6/ConfigParser.py", line 311, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'Plymouth Theme'

Mario Guerriero (mefrio-g) said : #4

install the latest version from the ppa....

RibShark (ribshark) said : #5

I have this bug too. I am using the latest version.

(It's installed on Debian, yes I know it's designed for Ubuntu, but I wanted to try it.) (New Linux user here, bare with me!)

NJ (joll-nicholas) said : #6

Same problem here, using the downloadable .deb and Mint 18.3.

NJ (joll-nicholas) said : #7

To install the 'hwinfo' module, this may suffice.

sudo -H pip install setuptools
sudo -H pip install python-hwinfo

The above seemed to work on my system (Mint). However, I know see this:

 $ plymouth-manager
Traceback (most recent call last):
  File "plymouth-manager.py", line 23, in <module>
    main.PlymouthManager()
  File "/usr/share/plymouth-manager/src/main.py", line 178, in __init__
    self.getCurrentTheme()
  File "/usr/share/plymouth-manager/src/main.py", line 209, in getCurrentTheme
    self.Theme = self.fileTheme.get("Plymouth Theme", "Name")
  File "/usr/lib/python2.7/ConfigParser.py", line 330, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'Plymouth Theme'

Can you help with this problem?

Provide an answer of your own, or ask Jon Winskill for more information if necessary.

To post a message you must log in.