clicking an icon opens a new app even if app already running (and should come to focus)

Asked by aaaa

Fedora 36 Linux, XFCE4.
All of a sudden clicking an icon on the Plank dashboard opens the app even if app is already running.
So I end up with many Firefox processes.
Usually, when I clicked on the icon of an already running app (e.g. Firefox or terminal), it would bring it into focus.
But now it spawns a new process for that app.
I think, but not absolutely sure, that this behavious started after a system update around 20-Sep-2022.

Question information

English Edit question
Plank Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Rico Tzschichholz (ricotz) said :
Revision history for this message
aaaa (aaa123123) said (last edit ):

Thank you very much for your help in this.
After I have today re-updated my Fedora36 the current libwnck3 library installed is still the same, i.e. the one which caused the problem:


(built on 19-Sep-2022).

So, it seems you nailed it. Although Fedora still needs some time (or some nudging) in upgrading the package).

I will wait until the package is updated in my computer and see if that fixes it. Unless you are absolutely certain that this is the culprit, in which case please close this issue now.

Plank is cool, thank you ALL for creating and maintaining it, thanks for all the free software,

Revision history for this message
aaaa (aaa123123) said (last edit ):

Fedora has issued an advisory which can be installed like
dnf upgrade --advisory FEDORA-2022-3e6188e500

BUT this did not work for me (and google does not any more tell me where I found the above command)

What did work for me was to downgrade the libwnck to a version back in Feb2022 (remember my system broke in Sep2022).

For example grab an rpm for your fedora system from here:

and then install it like:
dnf downgrade libwnck3-40.1-1.fc36.x86_64.rpm

It may be necessary to downgrade the "devel" version as well if you intend to build plank from sources:
dnf downgrade libwnck3-devel-40.1-1.fc36.x86_64.rpm

That solved it for me but it is a temporary solution, I am sure some package will complain about not having the latest libwnck. Oh well Fedora will probably soon crack this. But then the Gnome will probably bug us with quite a few more of this ...

Thanks people of plank and FSF!!!