How to stop an application appearing in the dock?

Asked by NJ on 2017-03-01

An icon for the Rainlendar desktop calendar appears on my Plank. This happens even though I have told Rainlendar not to show a tray icon. If I do tell it to show a tray icon, Plank registers two windows, i.e. shows a Rainlendar icon and puts two dots under it. Since Rainlendar just sits on the desktop - like Conky, which, happily, I don't see an icon for in Plank - I want to exclude Rainlendar from Plank. But how?

Also: oddly, while on boot I see the behaviour I have described, no Rainlendar icon appears if I close Rainlendar and then open it again *from the terminal*. (If I open it via a menu, I do get the icon.) EDIT: Actually, whether or not an icon appears seems random. Sometimes it does - though always or almost always on startup - and sometimes it doesn't.

Mint 18 Cinnamon.

Question information

Language:
English Edit question
Status:
Solved
For:
Plank Edit question
Assignee:
No assignee Edit question
Solved by:
NJ
Solved:
2017-03-07
Last query:
2017-03-07
Last reply:
Peter Feichtinger (shippo) said : #1

I think this is probably a problem with Rainlender, especially as it works fine for other apps.

I don't know if this is related, but I have a similar problem with the Xfce panel: sometimes when I edit the settings of the panel, there's an icon for the panel in Plank. It goes away when I restart Plank, however so it's no big deal.

NJ (joll-nicholas) said : #2

Thanks for the reply.

I've solved the problem. Rainlendar can run more than one 'skin' / set of windows at once, and each has an option to show a tray icon. Since there seems also to be a general (/global) option for a tray icon, I disabled that latter option - and had the problem. Disabling the per-skin tray icons solved the problem.