Firefox two versions on the plank dock

Asked by Simon on 2015-03-20

Hi,

I use elementary OS 0.3 Freya (32-bit) and i need two version of Firefox.

I also downloaded https://nightly.mozilla.org/ and installed ~/opt/firefox. In ~/.local/share/applications/ i am create file "Firefox Nightly 39.0a1" this file containe: http://paste.ubuntu.com/10634145/.

But for some reason and i have unusable configuration. See video https://www.dropbox.com/s/7ar5yg0chvulbjd/firefox.ogv?dl=0

Default Firefox and nightly build collapsed in one icon. Where did I err?

Best Regards.

Question information

Language:
English Edit question
Status:
Answered
For:
Plank Edit question
Assignee:
No assignee Edit question
Last query:
2015-03-28
Last reply:
2015-03-30
Rico Tzschichholz (ricotz) said : #1

Check both for their WM_CLASS in case of the default firefox it should be WM_CLASS(STRING) = "Navigator", "Firefox".

If you are lucky then the nightly defines a different one which you need to add to your custom desktop-file, like StartupWMClass=FirefoxNightly

You can use "xprop" to determine the wmclass.

Simon (sam-ua) said : #2

Add to my custom desktop-file "StartupWMClass=FirefoxNightly" not working and "xprop" shows WM_CLASS(STRING) = "Navigator", "Firefox".

If change exec section in custom desktop-file on: "Exec=...firefox -P beta -profile .../myprof --class='FirefoxNightly'" then

$ xprop WM_CLASS
WM_CLASS(STRING) = "Navigator", "FirefoxNightly"

And temporarily Plank, Firefox and Nightly begin to work as I want, but after several launches NewWindow/NewPrivateWindow on standart Firefox and Nignhtly is broken again((

Rico Tzschichholz (ricotz) said : #3

This seems to be a problem of with firefox. I have played with it a bit.

Starting the firefox-nightly with a custom launcher which properly passes a custom wmclass work fine. If the nightly is restarted it looses that wmclass and obviously can't be properly matched anymore.

Having one firefox-release instance running will result in activating it if trying to start the firefox-nightly. So -new-instance is mostly required to work around that.

Simon (sam-ua) said : #4

My last ~/.local/share/applications/FirefoxNightly39.0a1.desktop http://paste.ubuntu.com/10708502/

In standart firefox desktop file(/usr/share/applications/firefox.desktop) iam add option -new-instance too.

This configuration is usable, but dont work right-click on Nightly and choice "Open a New Window" and "Open a New Private Window", but I had use option -no-remote.

Can you help with this problem?

Provide an answer of your own, or ask Simon for more information if necessary.

To post a message you must log in.