Installation Problems

Asked by Andrew on 2014-12-11

When I try to install 0.7.1, once I enter 'make' I get this message:

/usr/bin/install: cannot create regular file ‘/usr/share/icons/hicolor/128x128/apps/plank.svg’: Permission denied
Makefile:377: recipe for target 'install-dist_pkgicon128DATA' failed
make[4]: *** [install-dist_pkgicon128DATA] Error 1
make[4]: Leaving directory '/home/dr-oq/Downloads/plank-0.7.1/data/icons'
Makefile:573: recipe for target 'install-am' failed
make[3]: *** [install-am] Error 2
make[3]: Leaving directory '/home/dr-oq/Downloads/plank-0.7.1/data/icons'
Makefile:532: recipe for target 'install-recursive' failed
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory '/home/dr-oq/Downloads/plank-0.7.1/data'
Makefile:475: recipe for target 'install-recursive' failed
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory '/home/dr-oq/Downloads/plank-0.7.1'
Makefile:771: recipe for target 'install' failed
make: *** [install] Error 2

I am running Ubuntu 14.10

Question information

Language:
English Edit question
Status:
Solved
For:
Plank Edit question
Assignee:
No assignee Edit question
Solved by:
Rico Tzschichholz
Solved:
2014-12-14
Last query:
2014-12-14
Last reply:
2014-12-12
Rico Tzschichholz (ricotz) said : #1

You did not just enter "make", but "make install" which requires root permissions if the installation prefix/target requires it.

Andrew (prk-andrew) said : #2

Could you give me some guidance on how to resolve my issue? It''s my first time using linux as an operating system

Best Rico Tzschichholz (ricotz) said : #3

Please read https://bazaar.launchpad.net/~docky-core/plank/trunk/view/head:/INSTALL which explains the needed procedures and inform yourself about using "sudo".

You should consider using a proper distro-package if available to avoid installing things manually and circumvent the packaging-system of your distribution.

Search for "autotools configure sudo make install".

Andrew (prk-andrew) said : #4

Thanks Rico Tzschichholz, that solved my question.