Plank not use my active icon theme

Asked by Frank Corona Prendes on 2014-12-01

Hi comunity, i be using the Dock Plank v0.7.1.1107 in Ubuntu Gnome 14.10 amd64 and the dock not use the icons of my active icon theme.

Question information

Language:
English Edit question
Status:
Answered
For:
Plank Edit question
Assignee:
No assignee Edit question
Last query:
2014-12-02
Last reply:
2016-08-12
Rico Tzschichholz (ricotz) said : #1

What makes you think this is the case?

If you properly installed and enabled a "gnome/gtk" icon-theme plank will use it. Of course this is not the case if an application or file on the dock is explicitly pointing to a custom-icon.

Frank Corona Prendes (yacuna) said : #2

To install my icon theme I followed the following steps:
1- Copy the package to / usr / share / icons
2-Then activate it using the 'gnome tweak tool'

The problem with the Plank is I do not see the option to change icons, I read on the web that takes default icons that applications are defined in / usr / share / applications but in my case is not the same.

I would recommend somewhere where you can download the Plank so that it can install, it may be that this broken my plank.

Rico Tzschichholz (ricotz) said : #3

Plank does not provide an option to explicitly change icons. It completely relies on gtk to pick up the correct icon. If your icon-theme does not include an icon it uses a fallback depending on some definitions. So make sure your theme actually includes the visible icons, you are using, in the dock. Better check again if you have it properly installed.

If this is problem with plank then there would be way more complaints. ;-)

bobzr (bobzr) said : #4

May I revive this old question. In fact I'm using plank on kde-plasma desktop and plank refuses to follow the system-wide icons theme. As Rico said plank completely relies on gtk to pick icons, I guess it must be a kde related issue. Should I put a symlink somewhere so that plank uses kde icons theme?

I have same issue as bobzr with linux mint kde, as he or she pointed out it may be due to the fact kde doesnt recognise gtk link properly, is there anything that can be done to use the kde icons? Thanks.

João Jotta (joaojotta) said : #7

So adding "Icon=/usr/share/icons/Numix-Circle/scalable/apps/thunderbird-branded.svg" to the, let's say, thunderbird.dockitem file won't change anything, right?

Erik Dubois (erik-dubois) said : #8

Found the solution - maybe Rico can make a fix
go to /home/.config/gtk-3.0

and change to

[Settings]
gtk-font-name=Noto Sans Regular 12
gtk-theme-name=Breeze
gtk-icon-theme-name=Sardi
gtk-fallback-icon-theme=default
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-menu-images=1
gtk-button-images=1

Erik Dubois (erik-dubois) said : #9

Forgot to mention the file name is settings.ini

bobzr (bobzr) said : #10

Thanks Erik Dubois, changing the settings.ini file did work. But I just realized there's a very simple way to do this in Plasma. Just go to settings /Application Style and then select GNOME Application Style (GTK). There you can put whatever Icon theme is installed, and Plank will follow. Only drawback it's necessary to log out and in to see the change.

Can you help with this problem?

Provide an answer of your own, or ask Frank Corona Prendes for more information if necessary.

To post a message you must log in.