Install method for 0.7.1

Asked by M4he on 2014-10-24

Been using 0.6.1 for quite a while and thought I'd update to 0.7.1 using my standard procedure:

1. Downloading and extracting the latest version via the green button on the right side of https://launchpad.net/plank
2. installing the build dependencies: "automake autoconf intltool libtool valac libxml2-utils libgtk-3-dev libbamf3-dev libwnck-3-dev libgee-dev gnome-common"
3. Exectuing "./configure", followed by "make"
4. using "sudo checkinstall" to build and install an artificial .deb package (also tried just using "sudo make install")

However, I can't get it to work this way anymore. When I try to execute "plank" I get the following error message: "plank: error while loading shared libraries: libplank.so.0: cannot open shared object file: No such file or directory".

When I have a look into the "src" folder of the directory where I built it, there's a bash script called "plank" which works if executed manually. However the "plank" binary in "src/.libs" produces the same error message as above. I suppose it's the same binary which is installed by make.
I can't find any additional instruction in the "INSTALL" document that differ from 0.6.1.

What am I missing here?

I'm using Ubuntu 14.04.1 LTS.

Question information

Language:
English Edit question
Status:
Solved
For:
Plank Edit question
Assignee:
No assignee Edit question
Solved by:
Rico Tzschichholz
Solved:
2014-10-24
Last query:
2014-10-24
Last reply:
2014-10-24
Best Rico Tzschichholz (ricotz) said : #1

Try passing the proper prefix to configure to have them install into the proper place:
./configure --prefix=/usr

Or simply use the available PPA while you are using ubuntu:
https://launchpad.net/~ricotz/+archive/ubuntu/docky

M4he (mahe) said : #2

Thanks Rico Tzschichholz, that solved my question.