No "Keep in Dock" option with program X?

Asked by Curious Guy on 2014-08-27

I put "program X" only because I'm not sure if this happens with other programs or not. Thus far it is only happening for me with Calibre. I'm running Manjaro and have installed Calibre which seems to run fine. I'm new to Linux and testing it out. Plank runs beautifully. I've installed a new theme (Numix) and have edited the .config/plank/dock1/settings file to have it show exactly how I want.

However, I run Calibre and the shortcut show up in Plank. However, when I right click, I do not have the option of "Keep in Dock." All you see is "Maximize," "Close All" and then the name of the program at the bottom. I'm including a link to an Imgur page that has a screenshot.

I am new to Linux and not sure if there is a way to create s shortcut to the Calibre program. Is there something I am doing wrong or an alternate way of adding an item by hand to Plank? If there is please explain as easily as possible because of how new I am to Linux.

Thank you for any help that you can give. Here is the link to the imgur screenshot: http://imgur.com/NLTRQVP

Question information

Language:
English Edit question
Status:
Answered
For:
Plank Edit question
Assignee:
No assignee Edit question
Last query:
2014-08-27
Last reply:
2016-11-01
Rico Tzschichholz (ricotz) said : #1

This means plank (and bamf) is not able to match the running Calibre-instance with the installed application-file (calibre.desktop/calibre-gui.desktop). Make sure you installed it properly and prefer the version shipped with your distribution.

Using calibre 1.48.0 on ubuntu utopic/14.10 here works fine.

I actually have the same issue but with other applications. Namely Chrome Stable (not Chromium) and Aptik so far. I'm on UbuntuMATE Vivid and using Plank 0.9.1.

Jason Byrne (jasonbyrne-att) said : #3

I have found that Plank will only read or see programs fully if the .desktop file of any program is in /usr/share/applications. If not, you won't get the option to check keep in dock. Run a file search for programname.desktop then once you find out where it is open your file manager as root and copy the .desktop file over to /usr/share/applications. I delete the .desktop from it's original location after I've placed it in /usr/share/applications. I'm about to do this now with winff on Xubuntu. I installed winff earlier and noticed I had no option to keep in dock. Not a big deal since I know how to handle this now. The change is immediate, no restart or log off/on required. Restart the program you're wanting to keep in dock and now you will have the option to keep in dock.

Rico Tzschichholz (ricotz) said : #4

user-specific/non-system desktop-files should be put in "~/.local/share/applications"

Jason Byrne (jasonbyrne-att) said : #5

@Rico : The only way I've been able to get the right click option to keep in dock is if the .desktop file of any program I want to keep in dock is in /usr/share/applications. I'm on Xubuntu 16.04

Update : WinFF .desktop file was already in /usr/share/applications, but no keep in dock check mark appeared. I looked through the .desktop file and noticed there were two additional GenericName lines under the first GenericName line. The addition two lines were for different languages, but still written in English, so that wasn't correct. As a start, I deleted the two addition GenericName files, saved the changes to the .desktop file, opened WinFF & right clicked, and then I had the option to keep in dock. Plank seems dependent on not only the .desktop file but also it's configuration. As always a simple fix.

Boyd Kelly (bkelly) said : #6

I'm having this issue with two java programs. I have put the desktop files in /usr/share/applications and also under .local/share/applications. Tried to simplify the files, made them executable or not. But Plank will not allow me to add them to the dock. I'm assuming that Rico's first answer in 2014 is the case, but is there any work-around here?

Go to Plank Preferences (Ctrl + Right Click on any icon -> Preferences) -> Behaviour and uncheck "Lock Items".

Gsus (jeguiluz) said : #8

I have de same problem whit double commnader app.

the solution is the same that is used to cairo-dock.

get the WM_CLASS properties from the program with problems.

You can find out which WM_CLASS your window has got when you type in a terminal:

xprop WM_CLASS

and then click at the window. In my case of the double commander app the output is as follows:

WM_CLASS(STRING) = "doublecmd", "Doublecmd"

put then in .desktop file at the end the following line:

StartupWMClass=doublecmd

save an then you can "keep on dock" in plank.

Can you help with this problem?

Provide an answer of your own, or ask Curious Guy for more information if necessary.

To post a message you must log in.