minimizing 'dead-ground'

Asked by Sharon Kimble on 2014-03-06

In every instance of 'plank', I have about a one-inch space above it where no buttons can be pressed in *any* programme, no pages moved between in tmux, and any interaction with any programme just doesn't happen! To make it happen I must physically move the programme out of the 'dead-space' and then it will interact again. This severely limits 'planks' usefulness as most other programmes have been shrunk out of the dead-space just to keep them working properly. So, how can I minimise this 'dead-space' or even get rid of it altogether please? This is on debian testing with fluxbox as my desktop environment.

Question information

Language:
English Edit question
Status:
Solved
For:
Plank Edit question
Assignee:
No assignee Edit question
Solved by:
Sharon Kimble
Solved:
2014-03-07
Last query:
2014-03-07
Last reply:
2014-03-06
Sharon Kimble (boudiccas) said : #1

After looking around a bit further, it seems that the problem lies with Bug #1272564, as I also have compton enabled. So I'm trying to see how it goes on with compton disabled.

Sharon Kimble (boudiccas) said : #2

It seems that 'plank-themer-ondock' needs compton or such like for any theme to work properly. Even the 'true-transparent' theme shows a grey background to plank, and is not transparent at all, whereas with compton or any other compositing manager working, it *is* transparent.

This seems to be a major problem with plank.

Rico Tzschichholz (ricotz) said : #3

You are mixing several issue together here. Plank doesn't support fake-transparency and therefore it won't be transparent if no compositing support is available. Theme's padding/radius values are adjusted to avoid the need for transparent areas.

The reported input-region problem seems to be restricted to fluxbox and therefore probably isn't a plank bug.

Sharon Kimble (boudiccas) said : #4

if you use 'compton' and call it as 'compton -c' you will see a large shadow at the bottom of the screen above plank. Kill plank and the shadow goes, start plank and it comes back, so its obviously coming from plank. Anything in this shadow is unclickable, and its this area that I am talking about.

Sharon Kimble (boudiccas) said : #5

The solution is to add this to your '~/.fluxbox/apps' file -
[app] (name=plank)
  [Layer] {bottom}
[end]

In use it may change {bottom} to {10} but it still seems to work okay.

Leonardo Nicolas (leonicolas) said : #6

For me this it not a final solution, only a workaround because when I used this configuration the plank bar was shown behind the maximized applications. In this case, if I want to access the plank bar, I need minimize all applications to access it.