Blurry icons when not using a .desktop file

Asked by M4he on 2013-06-08

I'm getting blurred icons for some applications which don't have a corresponding .desktop file. For example: xfrun4, gpartedbin and pkexec's authentication dialog (i.e. when starting "synaptic-pkexec").
Oddly enough, they are displayed with the correct icons from my Faenza icon set but in blurry low resolution.
I managed to fix xfrun4 and gpartedbin by creating .desktop files within /usr/share/applications/ using "Exec=xfrun4"/"Exec=gpartedbin" and "Icon=XXX". However I'm not able to fix the pkexec dialog which seems to be a window of the process "polkit-gnome-authentication-agent-1" according to xprop, but I had no luck using "Exec=polkit-gnome-authentication-agent-1".

1. Why do processes without a .desktop file receive correct but blurry icons? Does BAMF provide the icon images or does Plank load them?
2. Is there another possibility besides creating .desktop files to associate icons? (some kind of user defined BAMF association list)
3. Any suggestion about the pkexec dialog icon?

Question information

Language:
English Edit question
Status:
Solved
For:
Plank Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Dyer
Solved:
2013-06-08
Last query:
2013-06-08
Last reply:
2013-06-08
M4he (mahe) said : #2

Any ideas regarding the questions mentioned above? :)

Best Robert Dyer (psybers) said : #3

Please comment on the bug report.

M4he (mahe) said : #4

Thanks Robert Dyer, that solved my question.

Tommy (panophobie) said : #5

I'm still having this bug with several apps like Terminal and Chrome