How to enable unity features?

Asked by bwat47 on 2012-12-13

I'm currently using the latest plank from the PPA on linux mint 14 cinnamon. The quicklists seem to work, but nothing else does (I get no progress bars when downloading things in firefox or chrome).

Do I need to install extra packages to get progressbars and badges?

Question information

English Edit question
Plank Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was reopened

Robert Dyer (psybers) said : #1

No extra packages.

You can't run Unity at the same time, it won't work.

bwat47 (bwat47) said : #2

I'm not running unity, just cinnamon

bwat47 (bwat47) said : #3

to clarify, I'm running plank and it was my understanding that plank supports unity features, such as progressbars on the dock when downloading things in chrome or firefox, but these things don't seem to be working for me in plank. Was just wondering if I needed to do anything to get them to work. I'm don't have unity installed or running. The only unity feature that seems to work for me in plank is quicklists.

Robert Dyer (psybers) said : #4

You need dbus running for it to work. Verify that.

Also you can run plank with the '-d' option to see some messages about Unity:

[DEBUG 20:13:05.269958] [Unity:123] Unity: Initalizing LauncherEntry support
[DEBUG 20:13:05.281668] [Unity:179] Unity: com.canonical.Unity lost


bwat47 (bwat47) said : #5

Here's what I get when I run plank -d:

brandon@brandon-lemu4 ~ $ plank -d
[INFO 21:14:18.341800] [AbstractMain:176] Plank version:
[INFO 21:14:18.341939] [AbstractMain:177] Kernel version: 3.5.0-19-generic
[INFO 21:14:18.342055] [AbstractMain:178] GLib version: 2.34.0
[INFO 21:14:18.342140] [AbstractMain:179] GTK version: 3.6.2
[INFO 21:14:18.342237] [AbstractMain:180] Wnck version: 3.4.3
[INFO 21:14:18.342326] [AbstractMain:181] Cairo version: 1.12.2
[INFO 21:14:18.342431] [AbstractMain:182] Pango version: 1.30.1
[INFO 21:14:18.407053] [WindowControl:57] Window-manager: Mutter (Muffin)
[DEBUG 21:14:18.407201] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/settings'
[DEBUG 21:14:18.407648] [DockItems:194] Reloading dock items...
[DEBUG 21:14:18.407835] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/nemo.dockitem'
[DEBUG 21:14:18.408385] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/audacious.dockitem'
[DEBUG 21:14:18.408670] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/google-chrome.dockitem'
[DEBUG 21:14:18.409052] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/pidgin.dockitem'
[DEBUG 21:14:18.409400] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/gnome-terminal.dockitem'
[DEBUG 21:14:18.409771] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/vlc.dockitem'
[DEBUG 21:14:18.410109] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/smuxi-frontend-gnome.dockitem'
[DEBUG 21:14:18.410375] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/gedit.dockitem'
[DEBUG 21:14:18.410728] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/gnome-control-center.dockitem'
[DEBUG 21:14:18.411111] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/dock1/launchers/synaptic.dockitem'
[DEBUG 21:14:18.412392] [DockItems:240] done.
[DEBUG 21:14:18.444463] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/theme/dock.theme'
[DEBUG 21:14:18.447790] [Preferences:298] Loading preferences from file '/home/brandon/.config/plank/theme/hover.theme'
[DEBUG 21:14:18.466994] [Unity:123] Unity: Initalizing LauncherEntry support
[DEBUG 21:14:18.488571] [DockWindow:207] dock window loaded

Dbus is running: brandon@brandon-lemu4 ~ $ ls -l /var/run/dbus/
total 4
-rw-r--r-- 1 root root 4 Dec 12 15:15 pid
srwxrwxrwx 1 root root 0 Dec 12 15:15 system_bus_socket

I have various apps that rely on dbus and they work fine (and I'm not sure if gnome and cinnamon would even run without dbus running)

Robert Dyer (psybers) said : #6

The other thing is to ensure the apps themselves have Unity support enabled. And that you have libunity installed.

bwat47 (bwat47) said : #7

The libunity packages currently installed are:


If those are all the necessary libraries and I'm not missing anything then I will look into chrome and firefox, thanks :)

bwat47 (bwat47) said : #8

Thanks Robert Dyer, that solved my question.

Robert Dyer (psybers) said : #9

What exactly solved it?

bwat47 (bwat47) said : #10

Oops, I had hit the wrong button, actually still not working. I tried thunderbird too, none of them seem to work for some reason when it comes to badges and/or progressbars.

bwat47 (bwat47) said : #11

hmm I installed update-manager and that seems to work, so I guess its something with chrome/firefox/thunderbird etc... maybe they only enable the integration features if they detect unity or something. Doesn't seem to be a plank issue

Robert Dyer (psybers) said : #12

You can also try copying a large file in Nautilus.

I'm not sure what else uses unity progress/badges.