firefox icon missed in plank

Asked by Clara on 2012-09-25

I have just installed plank in my ubuntu 12.04 gnome fallback laptop (hpcompaq 6720S). The icon for firefox launcher in plank is missed, it shows a general icon of an executable program but not the icon I have addressed in the path in firefox.desktop. where can I force it ?

Question information

Language:
English Edit question
Status:
Solved
For:
Plank Edit question
Assignee:
No assignee Edit question
Solved by:
Clara
Solved:
2012-09-28
Last query:
2012-09-28
Last reply:
2012-09-25
Robert Dyer (psybers) said : #1

This should be filed as a bug.

Clara (claracagigal) said : #2

Thank you. I will report as a bug

Clara (claracagigal) said : #3

Although I have reported the problem as a bug, I have solved the problem in the following way: in the firefox.desktop file in the lines begining by Icon= and Icon [es-Es]= i have write the complete path to the firefox icon which is a png image. After that, the firefox launcher appears with its proper icon.