I've got a problem with pipelight installation.

Asked by Kosta Yakovlev on 2016-10-29

Well i need to install unity web player on kali linux.
Yesterday i've solved my problem with ubuntu pretty fast..but somehow kali seems to make problem for me.

 apt-get install pipelight-multi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pipelight-multi : Depends: ttf-mscorefonts-installer but it is not going to be installed
                   Depends: wine-staging
E: Unable to correct problems, you have held broken packages.

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2016-12-03
Last query:
2016-12-03
Last reply:
2016-11-04
Manfred Hampl (m-hampl) said : #1

You have to enable the multiverse repository to install ttf-mscorefonts-installer

Kosta Yakovlev (healer1982) said : #2

1st step is finished thank you.at least
than im getting back to the same problem with wine

root@kali:~# apt-get install pipelight-multi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pipelight-multi : Depends: wine-staging
E: Unable to correct problems, you have held broken packages.

Manfred Hampl (m-hampl) said : #3

What is the output of the following diagnostic command

apt-cache policy pipelight-multi wine-staging

Kosta Yakovlev (healer1982) said : #4

root@kali:~# apt-cache policy pipelight-multi wine-staging
pipelight-multi:
  Installed: (none)
  Candidate: 0.2.8.2~jessie
  Version table:
     0.2.8.2~jessie 500
        500 http://repos.fds-team.de/stable/debian jessie/main amd64 Packages
     0.2.8.1-1 500
        500 http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0 ./ Packages
wine-staging:
  Installed: (none)
  Candidate: 1.9.21~jessie
  Version table:
     1.9.21~jessie 500
        500 http://repos.fds-team.de/stable/debian jessie/main amd64 Packages
     1.7.51~ubuntu12.04.1 500
        500 http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0 ./ Packages

Manfred Hampl (m-hampl) said : #5

What do you get for the command

sudo apt-get install pipelight-multi wine-staging

Kosta Yakovlev (healer1982) said : #6

root@kali:~# sudo apt-get install pipelight-multi wine-staging
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging : Depends: wine-staging-i386 (= 1.9.21~jessie)
E: Unable to correct problems, you have held broken packages.

Manfred Hampl (m-hampl) said : #7

ok, and what is now the output of

apt-cache policy wine-staging-i386
sudo apt-get install wine-staging-i386

Additionally please provide also the output of the commands

uname -a
lsb_release -crid
sudo apt-get update
sudo apt-get dist-upgrade

Kosta Yakovlev (healer1982) said : #8

root@kali:~# apt-cache policy wine-staging-i386
wine-staging-i386:i386:
  Installed: (none)
  Candidate: 1.9.21~jessie
  Version table:
     1.9.21~jessie 500
        500 http://repos.fds-team.de/stable/debian jessie/main i386 Packages
     1.7.51~ubuntu12.04.1 500
        500 http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0 ./ Packages

sudo apt-get install wine-staging-i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libx11-6 : Depends: libxcb1 (>= 1.2) but it is not going to be installed
 wine-staging-i386:i386 : Depends: libasound2:i386 (>= 1.0.16)
                          Depends: libc6:i386 (>= 2.17) but it is not going to be installed
                          Depends: libexif12:i386 (>= 0.6.21-1~) but it is not going to be installed
                          Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                                   libgl1:i386
                          Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                          Depends: libglu1-mesa:i386 but it is not going to be installed or
                                   libglu1:i386
                          Depends: libgphoto2-6:i386 (>= 2.5.2) but it is not going to be installed
                          Depends: libgphoto2-port10:i386 (>= 2.5.2) but it is not going to be installed
                          Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                          Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                          Depends: liblcms2-2:i386 (>= 2.2+git20110628) but it is not going to be installed
                          Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                          Depends: libmpg123-0:i386 (>= 1.13.7) but it is not going to be installed
                          Depends: libopenal1:i386 (>= 1.14) but it is not going to be installed
                          Depends: libpulse0:i386 (>= 0.99.1) but it is not going to be installed
                          Depends: libudev1:i386 (>= 183) but it is not going to be installed
                          Depends: libx11-6:i386 but it is not going to be installed
                          Depends: libxext6:i386 but it is not going to be installed
                          Depends: libxml2:i386 (>= 2.9.0) but it is not going to be installed
                          Depends: zlib1g:i386 (>= 1:1.1.4) but it is not going to be installed
                          Depends: libasound2-plugins:i386 but it is not going to be installed
                          Depends: libncurses5:i386 but it is not going to be installed
                          Recommends: libcairo2:i386 (>= 1.2.4) but it is not going to be installed
                          Recommends: libcapi20-3:i386 but it is not going to be installed
                          Recommends: libcups2:i386 (>= 1.4.0) but it is not going to be installed
                          Recommends: libdbus-1-3:i386 (>= 1.0.2) but it is not going to be installed
                          Recommends: libfontconfig1:i386 (>= 2.11) but it is not going to be installed
                          Recommends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
                          Recommends: libgnutls-deb0-28:i386 (>= 3.3.0) but it is not going to be installed
                          Recommends: libgsm1:i386 (>= 1.0.13) but it is not going to be installed
                          Recommends: libgtk-3-0:i386 (>= 3.0.0) but it is not going to be installed
                          Recommends: libjpeg62-turbo:i386 (>= 1.3.1) but it is not going to be installed
                          Recommends: libncurses5:i386 (>= 5.5-5~) but it is not going to be installed
                          Recommends: libodbc1:i386 (>= 2.3.1) but it is not going to be installed
                          Recommends: libosmesa6:i386 (>= 10.2~) but it is not going to be installed
                          Recommends: libpcap0.8:i386 (>= 0.9.8) but it is not going to be installed
                          Recommends: libpng12-0:i386 (>= 1.2.13-4) but it is not going to be installed
                          Recommends: libsane:i386 (>= 1.0.11-3) but it is not going to be installed
                          Recommends: libtiff5:i386 (>= 4.0.3) but it is not going to be installed
                          Recommends: libtxc-dxtn-s2tc0:i386 but it is not going to be installed
                          Recommends: libv4l-0:i386 (>= 0.5.0) but it is not going to be installed
                          Recommends: libva-drm1:i386 (>= 1.1.0) but it is not going to be installed
                          Recommends: libva-x11-1:i386 (>= 1.0.3) but it is not going to be installed
                          Recommends: libva1:i386 (>= 1.0.3) but it is not going to be installed
                          Recommends: libx11-xcb1:i386 but it is not going to be installed
                          Recommends: libxcomposite1:i386 (>= 1:0.3-1) but it is not going to be installed
                          Recommends: libxcursor1:i386 (> 1.1.2) but it is not going to be installed
                          Recommends: libxi6:i386 but it is not going to be installed
                          Recommends: libxinerama1:i386 but it is not going to be installed
                          Recommends: libxrandr2:i386 but it is not going to be installed
                          Recommends: libxrender1:i386 but it is not going to be installed
                          Recommends: libxslt1.1:i386 (>= 1.1.25) but it is not going to be installed
                          Recommends: libxxf86vm1:i386 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

root@kali:~# uname -a
Linux kali 4.6.0-kali1-amd64 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) x86_64 GNU/Linux

root@kali:~# lsb_release -crid
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: kali-rolling
Codename: kali-rolling

sudo apt-get update
Ign:2 http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0 ./ InRelease
Ign:4 http://ftp.de.debian.org/debian wheezy InRelease
Get:5 http://repos.fds-team.de/stable/debian jessie InRelease [2,513 B]
Hit:6 http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0 ./ Release
Hit:7 http://ftp.de.debian.org/debian wheezy Release
Ign:5 http://repos.fds-team.de/stable/debian jessie InRelease
Get:3 http://debian.grena.ge/debian jessie-updates InRelease [145 kB]
Ign:1 http://debian.asis.io/debian jessie InRelease
Hit:10 http://mirror.isoc.org.il/pub/debian jessie Release
Get:12 http://security.debian.org jessie/updates InRelease [63.1 kB]
Fetched 211 kB in 4s (50.8 kB/s)
Reading package lists... Done
W: GPG error: http://repos.fds-team.de/stable/debian jessie InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E49CC0415DC2D5CA
W: The repository 'http://repos.fds-team.de/stable/debian jessie InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0/./Release.gpg: Signature by key 39D9F63CD74480C02715B0360134EBA3CAA5DFC8 uses weak digest algorithm (SHA1)
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:11
W: Target Translations (en_US) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:11
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:11
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:13
W: Target Translations (en_US) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:13
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:13
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:11
W: Target Translations (en_US) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:11
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:11
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:13
W: Target Translations (en_US) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:13
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:9 and /etc/apt/sources.list:13

root@kali:~# sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libdirectfb-1.2-9 libsdl1.2debian
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Manfred Hampl (m-hampl) said : #9

I see a mixture of different sources (e.g. Debian wheezy and jessie) which apparently provide software versions that are conflicting to each other.
Sorry, but this goes far beyond my knowledge of Kali Linux that I could propose a solution.

The only suggestion that I can make is a drastic reduction of extra repositories. Maybe you can then install pipeline (and wine-staging). If really necessary you could re-enable more sources afterwards. (Maybe the key is to remove the fds-team/Debian/jessie repository. Then the package management should try wine-staging provided by the opensuse/DarkPlayer/pipelight repository, maybe the dependencies of that one can be met.)

Additional remarks: lines 11 and 13 in sources.list seem to be duplicates of line 9, this leads to several warning messages.

You are missing the signature key of fds-team, see the first part of http://pipelight.net/cms/install/installation-debian.html for instructions how to install it (wget and apt-key commands).

Kosta Yakovlev (healer1982) said : #10

Ok,ive fixed smt,lets start it from the begging

sudo apt-get install pipelight-multi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pipelight-multi : Depends: wine-staging
E: Unable to correct problems, you have held broken packages.

sudo apt install wine-staging
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging : Depends: wine-staging-i386 (= 1.9.22~jessie)
E: Unable to correct problems, you have held broken packages.

sudo apt install wine-staging-i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libgphoto2-port10:i386 (>= 2.5.2) but it is not installable
                          Recommends: libcapi20-3:i386 but it is not going to be installed
                          Recommends: libcups2:i386 (>= 1.4.0) but it is not going to be installed
                          Recommends: libgnutls-deb0-28:i386 (>= 3.3.0) but it is not installable
                          Recommends: libgtk-3-0:i386 (>= 3.0.0) but it is not going to be installed
                          Recommends: libodbc1:i386 (>= 2.3.1) but it is not going to be installed
                          Recommends: libosmesa6:i386 (>= 10.2~) but it is not going to be installed
                          Recommends: libpcap0.8:i386 (>= 0.9.8) but it is not going to be installed
                          Recommends: libpng12-0:i386 (>= 1.2.13-4) but it is not installable
                          Recommends: libsane:i386 (>= 1.0.11-3) but it is not going to be installed
                          Recommends: libtxc-dxtn-s2tc0:i386
                          Recommends: libv4l-0:i386 (>= 0.5.0) but it is not going to be installed
                          Recommends: libxcomposite1:i386 (>= 1:0.3-1) but it is not going to be installed
                          Recommends: libxcursor1:i386 (> 1.1.2) but it is not going to be installed
                          Recommends: libxinerama1:i386 but it is not going to be installed
                          Recommends: libxrandr2:i386 but it is not going to be installed
                          Recommends: libxslt1.1:i386 (>= 1.1.25) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Manfred Hampl (m-hampl) said : #11

You might try installing aptitude, which can give more and better information with respect to dependency problems and resolution.

What is the output of
aptitude why-not pipelight-multi

What are the current contents of your sources.list configuration file?

Kosta Yakovlev (healer1982) said : #12

deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
# deb-src http://http.kali.org/kali kali-rolling main contrib non-free

deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
deb http://repos.fds-team.de/stable/debian/ jessie main

E: Invalid operation why-not

Best Manfred Hampl (m-hampl) said : #13

ok, apparently you version of aptitude does not know the why-not operation.

Then let's try manually:
What is the output of
apt-cache policy pipelight-multi wine-stagingwine-staging-i386 libgphoto2-port10:i386

I assume the problem is the libgphoto2-port10 package. kali-rolling apparently contains the newer libgphoto2-port12.
You might try manually installing libgphoto2-port10:i386 from Debian jessie or Ubuntu sources.
Then retry installing pipelight-multy, preferably without recommended packages:
sudo apt-get install --no-install-recommends pipelight-multi

Kosta Yakovlev (healer1982) said : #14

Thanks Manfred Hampl, that solved my question.