Text doesnt show in Unity games

Asked by Camille Philippon on 2016-01-20

Greetings!

I'm running Xubuntu 15.10 64 bits
I just finished to install Unity web player on Firefox, following the steps provided on the Pipelight website.

The game I want to play is loading fine, but all the text disappeared (I played the game before, I know it's missing). I can't see any letters on the buttons/description boxes...
I have the mscorefonts installed (got it with wine install). I double-checked with Synaptics to be sure, the package is there.

So... what should I do to make the fonts show in Unity?

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
Camille Philippon
Solved:
2016-01-20
Last query:
2016-01-20
Last reply:

Hi again!

Well it seems I found a working solution to my problem.

After some more reaserches, I found and read
https://bugs.launchpad.net/pipelight/+bug/1316138
and understood the problem.

I just copied all the files in
/usr/share/fonts/truetype/msttcorefonts/
and pasted them in both
/home/MYNAME/.wine-pipelight/drive_c/windows/Fonts/
and
/home/MYNAME/.wine-pipelight64/drive_c/windows/Fonts/

I understand it is not the most elegant way to do it, but it worked; Unity web player now displays text without problems.

Sorry to come back to answer my own question, but if it can help someone, all the better.