Pipelight (Silverlight) plugin doesn't work in Firefox 30 and Ubuntu 14.04

Asked by Qfito on 2015-07-09

Hi all, I have the need to use "Lync Web App" on Linux to attend Meetings. However is required the Silverlight plugin, I followed the instructions of the official site for pipelight installation, but has not worked and the plugin does not appear in "about: plugins" firefox.

Official installation procedure:

sudo add-apt-repository ppa:pipelight/stable
sudo apt-get update
sudo apt-get install --install-recommends pipelight-multi
sudo pipelight-plugin --update

I've run some commands but has not been able to correct the problem.

pipelight-plugin --disable silverlight5.1 --enable silverlight5.0
sudo pipelight-plugin --create-mozilla-plugins

Command Output (errors in libraries):

pipelight-plugin --system-check

Checking libraries...

libnetapi.so: missing

Libraries: FAILURE

>> 64 bit <<

Checking libraries...

libnetapi.so: missing

Libraries: FAILURE

Could you support me with this problem please?

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
Qfito
Solved:
2015-07-16
Last query:
2015-07-16
Last reply:
2015-07-15
Michael Müller (mqchael) said : #1

Hi,

sorry for the late answer, but I don't have much time for pipelight at the moment. I would suggest to do the following:

I am not sure if you mixed up system wide and user plugins, so first disable all plugins:
sudo pipelight-plugin --disable-all
pipelight-plugin --disable-all

Now enable silverlight 5.1 again:
sudo pipelight-plugin --enable silverlight

Force Firefox to reload the plugin:
sudo pipelight-plugin --create-mozilla-plugins

and test if it works now.

Michael

Qfito (gary-mayet) said : #2

Hello Michael, thank you very much for your answer. It seems that something happens when you installed the traditional way silverlight plugin. The way it worked was only changing version 5.1 to 5.0 and forcing reload firefox plugin.

pipelight-plugin --disable silverlight5.1 --enable silverlight5.0
sudo pipelight-plugin --create-mozilla-plugins

In the original question I had already done this, but really was missing the last command

sudo pipelight --create-plugin-mozilla-plugins

Greetings and thanks for everything