eurosport player changes

Asked by viksan on 2015-06-11

Hello everybody eurosportplayer use silverlight for their platform and works pretty well with pipelight since today. They made some changes that pipelight can`t hadle. For example I can`t switch between channels.

Does everybody here use Eurosport player ?

Question information

Language:
English Edit question
Status:
Answered
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Last query:
2015-06-12
Last reply:
2015-07-20
Michael Müller (mqchael) said : #1

You can fix this problem on two ways, either start your browser from a terminal (close all other browser windows first) using the following command line:

PIPELIGHT_WINDOWLESSMODE=2 firefox

or you can change the pipelight config:

cp /usr/share/pipelight/configs/pipelight-flash ~/.config/

Now open ~/.config/pipelight-flash using an editor (for example gedit ~/.config/pipelight-flash) and change

linuxWindowlessMode = false
- to -
linuxWindowlessMode = true

save and restart your browser.

viksan (viktor-stanoev) said : #2

Hi Michael thanks for your response.

This actually fix my problem now everything works I can switch between channels etc I receive audio but I don`t receive video. Only black screen show`s up with audio that`s all.

Any suggestions about that big issue?

Sebastien Douche (sdouche) said : #3

Same issue here: I've now the menu, audio but the screen is black.

ntz (ntz) said : #4

I have the same issue and any kind of workaround would be greatly appreciated. In the previous version all the channel/volume/language controls were embedded into the silverlight player but now they are made in html/javascript.

It should be noted that the intro/advertismenet video in the background of eurosport player is playing using flash when you are not logged in so verifying the silverlight version requires logging in.

Dan Watkins (oddbloke) said : #5

Setting PIPELIGHT_WINDOWLESSMODE=2 has given me the same result that viksan saw; I get audio and the controls, but no video.

I've also tried (in combination with the above environment variable), PIPELIGHT_GPUACCELERATION=0, PIPELIGHT_GPUACCELERATION=2 and PIPELIGHT_EMBED=0. None of these helped.

Michael, if there's anything else I can do to help you debug the issue, please let me know.

Michael Müller (mqchael) said : #6

I don't have an eurosport account and therefore can not really test it. Using PIPELIGHT_EMBED=0 should help though. It is not very user friendly as the controls should be shown in the browser while the video is displayed in an external window.

Dan Watkins (oddbloke) said : #7

Hi Michael,

On 16/06/15 02:13, Michael Müller wrote:
> I don't have an eurosport account and therefore can not really test it.

I'd be happy to share my credentials with you, if that would help. I
can't use it a great deal at the moment anyway, so it would be no great
loss. :p

> Using PIPELIGHT_EMBED=0 should help though. It is not very user friendly
> as the controls should be shown in the browser while the video is
> displayed in an external window.

I don't see the video showing in an external window[0]; do you have an
example page where you know this to work, so I can confirm that
disabling embedding works elsewhere?

Thanks again,

Dan

[0] The Firefox console log does show that embedded mode is disabled.

Miguel (xadrezmiguelpires) said : #8

Same Problem for me! If Michael wana credencials to solve this I can give to him.

viksan (viktor-stanoev) said : #9

Any chance someone to fix this issue?

John Baker (jksj-baker) said : #10

The light version just about works in firefox.
URL www.eurosportplayer.co.uk/live-light.shtml
to get full screen to work, right click on the silverlight window and untick 'Embed into Browser'
Every think then works fine, better quality video than in windows.

For some reason starting firefox with PIPELIGHT_WINDOWLESSMODE=2 firefox does not work.

Can you help with this problem?

Provide an answer of your own, or ask viksan for more information if necessary.

To post a message you must log in.