Unmeetable dependencies: wine-staging on Debian Sid

Asked by Doug on 2015-05-20

I'm running Siduction (amd64 fork of Debian Sid), struggled to work my way through the dependency problems. Basically, it's dependent on a whole list of i386 packages and one cannot be installed. I set up the pipeline repository and tried to install, at different times: 'wine-staging', 'wine-staging-amd64', and 'wine-staging-compat', but they all fail as "broken".

Further examination shows that they're dependent on libgphoto2-port10:i386, but the i386 architecture is not packaged for Sid (unstable), it is for Jessie (stable). I downloaded that package from Jessie (packages.debian.org), ran dpkg to install it, noted the missing dependent packages, then ran aptitude to install those packages and configure libgphoto2 (those other packages are available in Sid), then installed wine-staging-compat... which worked.

I wanted to pass on the details, since it stumped me for a couple hours.

Question information

Language:
English Edit question
Status:
Answered
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Last query:
2015-05-20
Last reply:
2015-05-22
Michael Müller (mqchael) said : #1

We are currently reworking our build system and part of this step is to reset all builders. This will definitely remove the no longer existing package and the next wine staging version should be linked against the correct gphoto package.

Can you help with this problem?

Provide an answer of your own, or ask Doug for more information if necessary.

To post a message you must log in.