Unity3d plugin not showing on Firefox

Asked by ILoveGurochan on 2015-05-14

Hi guys!
I'm using Kubuntu 14.04 and i was trying to re-install all my pipelight plugins.I had x64-flash and stable unity3d installed because i had issues with the Adobe Flash Player update so i had to reinstall it.
But both plugins disappeared and i worked for an hour or more to reinstall them.Flash player now works correctly but i couldn't be able to install unity3d again.I tried everything,from rebooting to modifying SHA into install-dependency.If i check --list-enabled unity3d is there but firefox doesn't show it and i ran out of ideas to fix it.

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Müller
Solved:
2015-05-23
Last query:
2015-05-23
Last reply:
2015-05-22

I checked and the .so is already into usr/lib/mozilla/plugins so i don't really understand why firefox doesn't get the plugin.

Best Michael Müller (mqchael) said : #2

Firefox blacklists plugins that take too long to load. This might be the case if you install a plugin for the first time. I would recommend to first update unity3d using

sudo pipelight-plugin --update

and restart your browser. If firefox still blacklists it, you can run "sudo pipelight-plugin --create-mozilla-plugins" and restart firefox.

Thanks Michael Müller, that solved my question.