Therian Saga login error

Asked by Charles Hawkins on 2015-05-02

I have 2 computers running Arch, 64 bit, LTS version, everything up to date. I've installed Pipelight using the Pipelight repository. The Bubblelight demo and Microsoft's Smooth Streaming demos work fine. However, when I try to go into (press "Play" button) Therian Saga which uses Silverlight, the screen goes white, then black, then a message box with "Login Failed", "Unknown Web Error". Then the splash screen appears in the background and the music starts to play. I click "Ok" and it takes me back to the home screen. Note that one must already be logged in to press the "Play" button, so the "Login Failed" is not a failed security check.

Other players on the forum are using Pipelight to play the game. I've also been in contact with one who is using Arch who doesn't have this problem. The only difference we've been able to see is that he doesn't have a .wine-pipelight64 directory whereas I have both that and a .wine-pipelight directory. I renamed the former to make sure it isn't being used and the Silverlight demos still run and nothing changes. I didn't think to ask him but most likely he isn't using Arch LTS which would be another difference.

I have a very old Ubuntu computer that I installed Pipelight on and it runs Therian Saga (painfully slowly) using the same Internet connection as my Arch computers. So I think I've eliminated it being anything to do with my Internet connection and think it must be something wrong with my Arch installation/configuration.

The "--system-check" fails on fonts (Verdana missing) and libraries (libcups, libnetapi, and libodbc) but I don't think any of those are present on the Ubuntu box either. I don't know enough to tell anything from the log.

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
Charles Hawkins
Solved:
2015-05-22
Last query:
2015-05-22
Last reply:
2015-05-08
Michael Müller (mqchael) said : #1

A debug log might reveal some more information (http://pipelight.net/cms/faqs/faq-how-to-capture-debug-output.html) and also add the full output of the system check. You will need to use some paste website as the question tracker does not allow attachments.

On Ubuntu you will have Verdana installed as the pipelight package depends on the ttf-mscorefonts-installer package. Silverlight runs into some weird issues if some fonts are misssing, so I would at least give it a try. You can either install the ttf-ms-fonts package from the AUR or use winetricks instead (WINEPREFIX=~/.wine-pipelight winetricks corefonts) to install the fonts.

The .wine-pipelight64 directory is only created when you are using a 64 bit plugin or run the system check. It therefore doesn't have any relation to Silverlight.

Thanks for the reply. I must have misspelled "verdana" when searching the Ubuntu box. You are correct, it is there.

winetricks gave me an error so I installed the AUR fonts package. --system-check still failed on fonts so I decided to try starting over again. I've since figured out too late that I needed to set the WINE var to /opt/... for winetricks.

I uninstalled pipelight, deleted the .wine-pipelight{64} directories and went through the installation procedure again. Now --system-check passes on the fonts. I agreed to the licenses message when enabling Silverlight. But Pipelight doesn't seem to be called by Firefox. The log file is empty except for the usual GLib error. The Bubblemark demo wants to download Silverlight from MS.

Searching through the answers, I ran across "--create-mozilla-plugins" which I've done and that has gotten Silverlight working again. Ignore my last message.

Fonts pass now but still have the same problem. The message box doesn't come up as quickly--instead it comes up after the splash screen and music. No idea if that's significant or simply the result of having no other tabs open.

Output from --system-check followed by debug output can be found at:
http://pastebin.com/JvP1Kn13

Michael Müller (mqchael) said : #5

Do you have any browser extensions enabled (like NoScript, Https everywhere)?

Flash Video Downloader and User Agent Overrider (because of Pipelight) are all.
Other plugins are Shockwave and OpenH264.

I tried disabling the Downloader and changed Shockwave to "Always Ask" but it didn't make any difference.

The latest Arch update which updated wine-staging to 1.7.42 seems to have fixed this. Of course, it could have been something else in the update as well.