Firefox crashes caused by pipelight-flash, Can't uninstall.

Asked by Ben McDonnell on 2015-03-14

I have been having lots of crashes, script errors and problems with Flash in Firefox recently.

In Firefox in my add-ons list I now have two Shockwave Flash plugin versions, 11.2.202.451 and 16.0.0.235. I can't remember how this happened. I know that 16.0.0.235 is pepperflash and used when Firefox runs in Wine, the windows emulator. I don't use Wine and don't need it. Furthermore, I cannot activate version 11 without v16 activating too, and I think v16 is causing the crashes, as the message I get , “pluginloader.exe encountered a serious problem and needs to close” is Windows related.

I want to remove v16 or permanently stop it activating.
I cannot see it anywhere else on the system except in the Firefox browser.
It's not in the /usr/lib/mozilla/plugins folder. Nearest thing to it is a file called pipelight-flash.so which I though was related to pepperflash.

There should be a wrapper called fresh player plugin, but can't find that either

I have tried to uninstall pipelight and terminal now says it is no longer installed, but I still have the pipelight files in/usr/lib, in moxilla folder and in a pipelight folder

My distro is Ubuntu 14.04

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
Ben McDonnell
Solved:
2015-03-14
Last query:
2015-03-14
Last reply:
Ben McDonnell (benmcd) said : #1

I have now removed pipelight successfully and finally, I hope, with Synaptic package manager