OpenSUSE 13.2: Firefox update to 36.x, pipelight no longer seen by browser

Asked by Steve Adams on 2015-03-03

After updating Firefox browser to v36.0, as supplied by the openSUSE 13.2 update repository, the browser no longer sees any pipelight plugin that has been installed. I have even gone so far as to completely disable all used plugins, deleted all hidden folder/file info for pipelight from the home directory, deleted all mozilla hidden files and directories, uninstalled pipelight, uninstalled Firefox, and reinstalled. The reinstall order was Firefox, pipelight, update pipelight with its update switch, enable the plugins, and start Firefox.

When firefox starts up after this procedure, Wine goes about creating the necessary hidden directories for pipelight and pipelight64 but Firefox never sees them. Instead, pages and sites that need pipelight show the "install Microsoft Silverlight" buttons and Flash-based sites that do not automatically switch to HTML5 show a missing plugin icon.

I am at my wits end with this whole pipelight thing. If I was not so frustrated, I would find it humorous. I am using the latest pipelight that is available from its official repository.

Am I doing something wrong or is this a problem with the latest Firefox update? It worked fine with the previous Firefox but is absolutely useless with v36.

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
Steve Adams
Solved:
2015-03-04
Last query:
2015-03-04
Last reply:
2015-03-03
Michael Müller (mqchael) said : #1

Hi,

I can not reproduce the issue on Ubuntu. Could you post a log when starting firefox and trying to use a plugin as described at http://pipelight.net/cms/faqs/faq-how-to-capture-debug-output.html ?

Launchpad does not provide any way to attach files to questions, so I would suggest to use a service like http://pastebin.com instead.

Michael

Steve Adams (sea4929) said : #2

Michael,

I did as you asked and ran the debug command from the referenced FAQ page:

firefox &>> pipelight.log

And this was the entireity of the log file's contents:

[USER]@[HOST]:~> cat pipelight.log

(process:23543): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

This was after I had cleanly reinstalled pipelight from its repository (which installed the wine-staging and wine-staging-32bit requirements), ran sudo pipelight-plugin --update, and enabled the flash and silverlight plugins with pipelight-plugin --enable [pluginname].

It looks like Firefox v36.0 is not even triggering wine to create the hidden .wine*/ directories in the user's home.

Any other ideas?

Steve Adams (sea4929) said : #3

An additional comment... Firefox ran fine. It did not crash with that error but it also did not generate any additional output while I went to some sites I know have silverlight and flash elements embedded.

My system is openSUSE 13.2 updated daily. I also am pulling gstreamer stuff from the Packman repository and that is also updated daily. I need the media files from the Packman directory for Second Life viewer apps as they use codecs that are not supplied in the openSUSE repos.

The installed version of Firefox is 36.0-14.2 and it is supplied by the openSUSE Main Update repo. If it matters, the openSUSE 21-4.1.2 branding package is also installed and applied to the browser, which is supplied by the openSUSE Main Repo (OSS).

Steve Adams (sea4929) said : #4

Ran firefox again just by itself in a comman line and this time it did not return the terminal back to the user prompt as it did the first couple of times I tried. I did not have it write to a log file but I did capture the output as printed on the terminal:

http://pastebin.com/iSxkJMWF

From what I could see, the installs of the flash, x64-flash, and silverlight plugins all failed. That would explain why Firefox did not see them.

Hope this helps.

Michael Müller (mqchael) said : #5

Do you have anything enabled like SELinux or Apparmor? This pretty much looks like the process is being killed. You might find additional information in the dmesg output.

Please execute the following command and post the output:

WINEPREFIX=~/.wine-pipelight/ WINE=/usr/share/pipelight/wine /usr/share/pipelight/install-dependency wine-silverlight5.1-installer

Steve Adams (sea4929) said : #6

Personally I have not enabled nor disabled either SELinux or Apparmor. I have literally just only reinstalled openSUSE after switching from Fedora 21 (where pipelight refused to work at all but no longer a concern for me). With regards to those two secure features, my system is running in whatever the default state that is installed out of the box.

Before I run those commands, I do wish to let you know that I have found a workaround to getting pipelight installed and running on firefox. It is a roundabout way but it is, for the most part, stable and running for what I needed it to do.

First, I deleted all instances of pipelight and mozilla files from their respective hidden directories in the home folder as well as the .cache, .config, and .local folders. Then I ran the Midori web browser which kicked off the installs for the flash, x64-flash, and silverlight plugins. While Midor is not very stable running those plugins itself, it was very helpful in making the plugins install without error. After shutting down Midori and running Firefox, I found it was now able to see and use the Silverlight and Flash plugins as expected.

The only glitch I have seen is that the Adobe Flash test page crashes the flash plugin after each cycle of the embedded program where I need to hit the "reload" button that the crash produces at the top of the page. Other than that, all other flash and silverlight bases sites I use seem to be working normally.

I am not sure why running Midori was able to make wine install the plugins whereas Firefox v36.0 could not but as far as I am concerned, I have answered the question I posted.

As for the output of the WINEPREFIX command you asked me to run, here is the output from that:

[install-dependency] wine-silverlight5.1-installer is already installed in '/home/adamsstephene/.wine-pipelight/'.

I guess that is to be expected since Midori and wine were able to install the plugins.

Thank you for your assistance. I consider my question answered but remain open to trying some things for you should the pipelight team have unanswered questions regarding this incident.

Hector (hsanjuan) said : #7

Hi,

I don't think this should be marked as solved.

It has happened to me with Firefox 36, 37, 38... the only way I've found is to remove ~/.wine-pipelight, start midori, close midori, start firefox, disable plugins, enable plugins, update, create mozilla plugins and repeat procedure.. and at some point Firefox picks it up. As I say happens on every Firefox update, and it also gets resolved by reverting the Firefox version. The Firefox output is just like pipelight was not there at all.

There are also similar reports: https://ask.fedoraproject.org/en/question/69471/pipelightsilverlight-plugin-not-active-in-firefox-but-is-in-konqueror/

I'll report back next Firefox update, to see if it still breaks or not.

omvsj (omvsj) said : #8

What I found is the problem were in firefox profile

/home/username/.mozilla/firefox/(profile).default/pluginreg.dat

The file said:
----------------------------------------------------------------------------
[INVALID]
/usr/lib/pipelight/libpipelight-silverlight5.1.so:$
1446944847000:$
----------------------------------------------------------------------------

And it should said:
----------------------------------------------------------------------------
libpipelight-silverlight5.1.so:$
/usr/lib/pipelight/libpipelight-silverlight5.1.so:$
5.1.40416.0:$
1446944847000:0:0:0:$
5.1.40416.0:$
Silverlight Plug-In:$
2
0:application/x-silverlight:npctrl:scr:$
1:application/x-silverlight-2:::$

[INVALID]
----------------------------------------------------------------------------

After changing the file and restarted firefox, silverlight worked perfectly.