unmet dependencies : wine-staging

Asked by Sven Pattyn on 2015-02-27

I'm having the following problem, trying to install Pipelight in Ubuntu 14.04 after adding the ppa and updating. Can someone help me?

sudo apt-get install --install-recommends pipelight-multi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pipelight-multi : Depends: wine-staging
E: Unable to correct problems, you have held broken packages.

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
Sven Pattyn
Solved:
2015-03-06
Last query:
2015-03-06
Last reply:
2015-03-05
brianclements (brianclements) said : #1

I'm having this problem too. For me, I think it's because I'm on a 64-bit computer and wine-staging keeps looking for wine-staging-i386 when wine-staging-amd64 is already installed. But clearly apt-get doesn't want to install the i386 version for obvious reasons.

[ root@zeus:/opt ]$ apt-get install pipelight-multi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pipelight-multi : Depends: wine-staging but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[ root@zeus:/opt ]$ apt-cache show wine-staging
Package: wine-staging
Priority: optional
Section: otherosfs
Installed-Size: 10566
Maintainer: Erich E. Hoover <email address hidden>
Architecture: amd64
Version: 1.7.37~ubuntu14.04.1
Depends: libc6 (>= 2.17), wine-staging-amd64 (= 1.7.37~ubuntu14.04.1), wine-staging-i386 (= 1.7.37~ubuntu14.04.1)
Pre-Depends: dpkg (>= 1.14.12ubuntu3)
Filename: pool/main/w/wine-staging/wine-staging_1.7.37~ubuntu14.04.1_amd64.deb
Size: 2676514
MD5sum: ae1c453503523a746ea7393adc1ef92c
SHA1: 62752cdbe1f8a3176ccb5c475caf3edc32673344
SHA256: c74874871875086b400e66f7578490812db13059a353058fa1ca53cc6439b80c
Description: The Staging Edition is a special build of the popular Wine software
Description-md5: 904554bf8456351d22b61f92cf72b092
Multi-Arch: foreign
Original-Maintainer: Scott Ritchie <email address hidden>

[ root@zeus:/opt ]$ apt-get install wine-staging
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging : Depends: wine-staging-i386 (= 1.7.37~ubuntu14.04.1) but it is not installable
E: Unable to correct problems, you have held broken packages.

[ root@zeus:/opt ]$ apt-get install wine-staging-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
wine-staging-amd64 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.

[ root@zeus:/opt ]$ apt-get install wine-staging-i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package wine-staging-i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'wine-staging-i386' has no installation candidate

Michael Müller (mqchael) said : #2

Hi,

it could be possible that you don't have multiarch support enabled. Please try the following:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install --install-recommends pipelight-multi

Michael

Sven Pattyn (sven-pattyn) said : #3

I've tried the multiarch support but it didn't solve my problem.
Apparently, the 32-bit seems to be the problem for me as well, but with a different output:

sudo apt-get install wine-staging-i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libglu1-mesa:i386 but it is not going to be installed or
                                   libglu1:i386
                          Depends: libgphoto2-6:i386 (>= 2.5.2) but it is not going to be installed
                          Depends: libgphoto2-port10:i386 (>= 2.5.2) but it is not going to be installed
                          Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                          Depends: libpulse0:i386 (>= 1:0.99.1) but it is not going to be installed
                          Depends: libasound2-plugins:i386 but it is not going to be installed
                          Recommends: libcups2:i386 but it is not going to be installed
                          Recommends: libfontconfig1:i386 but it is not going to be installed or
                                      libfontconfig:i386
                          Recommends: libfreetype6:i386 but it is not going to be installed
                          Recommends: libsane:i386 but it is not going to be installed
                          Recommends: libva-x11-1:i386 but it is not going to be installed
                          Recommends: libxt6:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

brianclements (brianclements) said : #4

Thanks Michael, using `sudo dpkg --add-architecture i386` worked for me for this particular issue. It proceeded to install both 32-bit AND 64-bit versions of everything, which was a bit crazy, but it technically fixed my stated issue above.

Michael Müller (mqchael) said : #5

Hi,

please post the output of "aptitude install wine-staging-i386". Aptitude is more verbose in such situations while apt-get does not show the actual problem.

Michael

Sven Pattyn (sven-pattyn) said : #6

This is the complete output for aptitude install wine-staging-i386:

sudo aptitude install wine-staging-i386
Note: selecting "wine-staging-i386:i386" instead of the
      virtual package "wine-staging-i386"
The following NEW packages will be installed:
  libasn1-8-heimdal:i386{a} libasound2:i386{a} libasound2-plugins:i386{a}
  libasyncns0:i386{a} libavahi-client3:i386{a} libavahi-common-data:i386{a}
  libavahi-common3:i386{a} libcapi20-3:i386{a} libcgmanager0:i386{ab}
  libcomerr2:i386{ab} libcups2:i386{a} libdb5.3:i386{a} libdbus-1-3:i386{a}
  libdrm-intel1:i386{ab} libdrm-nouveau2:i386{ab} libdrm-radeon1:i386{ab}
  libdrm2:i386{ab} libelf1:i386{a} libexif12:i386{a} libexpat1:i386{a}
  libffi6:i386{a} libflac8:i386{a} libfontconfig1:i386{a}
  libfreetype6:i386{ab} libgcrypt11:i386{a} libgd3:i386{a}
  libgl1-mesa-dri:i386{a} libgl1-mesa-glx:i386{a} libglapi-mesa:i386{a}
  libglu1-mesa:i386{a} libgnutls26:i386{a} libgpg-error0:i386{a}
  libgphoto2-6:i386{a} libgphoto2-port10:i386{a} libgsm1:i386{a}
  libgssapi-krb5-2:i386{ab} libgssapi3-heimdal:i386{a}
  libhcrypto4-heimdal:i386{a} libheimbase1-heimdal:i386{a}
  libheimntlm0-heimdal:i386{a} libhx509-5-heimdal:i386{a} libice6:i386{a}
  libieee1284-3:i386{a} libjack-jackd2-0:i386{a} libjbig0:i386{a}
  libjpeg-turbo8:i386{a} libjpeg8:i386{a} libjson-c2:i386{a}
  libk5crypto3:i386{ab} libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a}
  libkrb5-3:i386{ab} libkrb5support0:i386{ab} liblcms2-2:i386{a}
  libldap-2.4-2:i386{a} libllvm3.4:i386{a} libltdl7:i386{a}
  liblzma5:i386{a} libmpg123-0:i386{a} libnih-dbus1:i386{a} libnih1:i386{a}
  libodbc1:i386{a} libogg0:i386{a} libopenal1:i386{a} libosmesa6:i386{a}
  libp11-kit0:i386{a} libpcap0.8:i386{a} libpciaccess0:i386{a}
  libpng12-0:i386{a} libpulse0:i386{ab} libroken18-heimdal:i386{a}
  libsamplerate0:i386{a} libsane:i386{a} libsasl2-2:i386{a}
  libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} libsm6:i386{a}
  libsndfile1:i386{a} libspeexdsp1:i386{a} libsqlite3-0:i386{a}
  libssl1.0.0:i386{a} libtasn1-6:i386{a} libtiff5:i386{a}
  libtxc-dxtn-s2tc0:i386{a} libudev1:i386{ab} libusb-1.0-0:i386{a}
  libuuid1:i386{ab} libv4l-0:i386{a} libv4lconvert0:i386{a}
  libva-x11-1:i386{a} libva1:i386{a} libvorbis0a:i386{a}
  libvorbisenc2:i386{a} libvpx1:i386{a} libwind0-heimdal:i386{a}
  libwrap0:i386{a} libx11-6:i386{a} libx11-xcb1:i386{a} libxau6:i386{a}
  libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} libxcb-glx0:i386{a}
  libxcb-present0:i386{a} libxcb-sync1:i386{a} libxcb1:i386{a}
  libxcomposite1:i386{a} libxcursor1:i386{a} libxdamage1:i386{a}
  libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} libxi6:i386{a}
  libxinerama1:i386{a} libxml2:i386{a} libxpm4:i386{a} libxrandr2:i386{a}
  libxrender1:i386{a} libxshmfence1:i386{a} libxslt1.1:i386{a}
  libxt6:i386{a} libxxf86vm1:i386{a} wine-staging-i386:i386 zlib1g:i386{a}
0 packages upgraded, 123 newly installed, 0 to remove and 6 not upgraded.

Need to get 26,2 MB/46,1 MB of archives. After unpacking 259 MB will be used.

The following packages have unmet dependencies:
 libgssapi-krb5-2 : Breaks: libgssapi-krb5-2:i386 (!= 1.12+dfsg-2ubuntu5.1) but 1.12+dfsg-2ubuntu4.2 is to be installed.
 libgssapi-krb5-2:i386 : Breaks: libgssapi-krb5-2 (!= 1.12+dfsg-2ubuntu4.2) but 1.12+dfsg-2ubuntu5.1 is installed.
 libdrm-intel1 : Breaks: libdrm-intel1:i386 (!= 2.4.56-1~ubuntu2) but 2.4.56-1~ubuntu1 is to be installed.
 libdrm-intel1:i386 : Breaks: libdrm-intel1 (!= 2.4.56-1~ubuntu1) but 2.4.56-1~ubuntu2 is installed.
 libkrb5-3 : Breaks: libkrb5-3:i386 (!= 1.12+dfsg-2ubuntu5.1) but 1.12+dfsg-2ubuntu4.2 is to be installed.
 libkrb5-3:i386 : Breaks: libkrb5-3 (!= 1.12+dfsg-2ubuntu4.2) but 1.12+dfsg-2ubuntu5.1 is installed.
 libcomerr2 : Breaks: libcomerr2:i386 (!= 1.42.9-3ubuntu1.2) but 1.42.9-3ubuntu1 is to be installed.
 libcomerr2:i386 : Breaks: libcomerr2 (!= 1.42.9-3ubuntu1) but 1.42.9-3ubuntu1.2 is installed.
 libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.56-1~ubuntu2) but 2.4.56-1~ubuntu1 is to be installed.
 libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.56-1~ubuntu1) but 2.4.56-1~ubuntu2 is installed.
 libfreetype6 : Breaks: libfreetype6:i386 (!= 2.5.2-1ubuntu2.3) but 2.5.2-1ubuntu2.2 is to be installed.
 libfreetype6:i386 : Breaks: libfreetype6 (!= 2.5.2-1ubuntu2.2) but 2.5.2-1ubuntu2.3 is installed.
 libcgmanager0 : Breaks: libcgmanager0:i386 (!= 0.24-0ubuntu7.3) but 0.24-0ubuntu7.2 is to be installed.
 libcgmanager0:i386 : Breaks: libcgmanager0 (!= 0.24-0ubuntu7.2) but 0.24-0ubuntu7.3 is installed.
 libuuid1 : Breaks: libuuid1:i386 (!= 2.20.1-5.1ubuntu20.4) but 2.20.1-5.1ubuntu20.3 is to be installed.
 libuuid1:i386 : Breaks: libuuid1 (!= 2.20.1-5.1ubuntu20.3) but 2.20.1-5.1ubuntu20.4 is installed.
 libudev1 : Breaks: libudev1:i386 (!= 204-5ubuntu20.10) but 204-5ubuntu20.9 is to be installed.
 libudev1:i386 : Breaks: libudev1 (!= 204-5ubuntu20.9) but 204-5ubuntu20.10 is installed.
 libdrm-nouveau2 : Breaks: libdrm-nouveau2:i386 (!= 2.4.56-1~ubuntu2) but 2.4.56-1~ubuntu1 is to be installed.
 libdrm-nouveau2:i386 : Breaks: libdrm-nouveau2 (!= 2.4.56-1~ubuntu1) but 2.4.56-1~ubuntu2 is installed.
 libpulse0 : Breaks: libpulse0:i386 (!= 1:4.0-0ubuntu11.1) but 1:4.0-0ubuntu11 is to be installed.
 libpulse0:i386 : Breaks: libpulse0 (!= 1:4.0-0ubuntu11) but 1:4.0-0ubuntu11.1 is installed.
 libdrm2 : Breaks: libdrm2:i386 (!= 2.4.56-1~ubuntu2) but 2.4.56-1~ubuntu1 is to be installed.
 libdrm2:i386 : Breaks: libdrm2 (!= 2.4.56-1~ubuntu1) but 2.4.56-1~ubuntu2 is installed.
 libkrb5support0 : Breaks: libkrb5support0:i386 (!= 1.12+dfsg-2ubuntu5.1) but 1.12+dfsg-2ubuntu4.2 is to be installed.
 libkrb5support0:i386 : Breaks: libkrb5support0 (!= 1.12+dfsg-2ubuntu4.2) but 1.12+dfsg-2ubuntu5.1 is installed.
 libk5crypto3 : Breaks: libk5crypto3:i386 (!= 1.12+dfsg-2ubuntu5.1) but 1.12+dfsg-2ubuntu4.2 is to be installed.
 libk5crypto3:i386 : Breaks: libk5crypto3 (!= 1.12+dfsg-2ubuntu4.2) but 1.12+dfsg-2ubuntu5.1 is installed.
open: 544; closed: 7121; defer: 267; conflict: 392
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1135; closed: 15622; defer: 285; conflict: 414
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1131; closed: 16216; defer: 291; conflict: 423
 Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1166; closed: 16691; defer: 313; conflict: 455
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1199; closed: 17142; defer: 341; conflict: 496
 Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1214; closed: 17580; defer: 351; conflict: 508
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1308; closed: 20300; defer: 373; conflict: 534
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1314; closed: 20858; defer: 374; conflict: 535
 .Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1320; closed: 21255; defer: 374; conflict: 535
  oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1326; closed: 21667; defer: 374; conflict: 535
  OInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1328; closed: 23137; defer: 377; conflict: 538
   OInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1333; closed: 23735; defer: 382; conflict: 543
  .Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1339; closed: 24181; defer: 388; conflict: 549
  oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1345; closed: 24435; defer: 393; conflict: 553
  OInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1371; closed: 26138; defer: 397; conflict: 558
   .Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1372; closed: 26555; defer: 400; conflict: 561
  oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1370; closed: 27044; defer: 403; conflict: 566
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1412; closed: 28524; defer: 440; conflict: 610
 .Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1421; closed: 28855; defer: 452; conflict: 624
  oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1437; closed: 29210; defer: 465; conflict: 638
 OInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1442; closed: 29382; defer: 470; conflict: 646
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1445; closed: 29651; defer: 473; conflict: 651
  .Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1568; closed: 36242; defer: 531; conflict: 729
  .Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1573; closed: 36538; defer: 533; conflict: 731
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1575; closed: 36802; defer: 533; conflict: 731
 OInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1578; closed: 36891; defer: 536; conflict: 736
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1585; closed: 37171; defer: 540; conflict: 744
  .Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1599; closed: 37279; defer: 552; conflict: 772
 oInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1602; closed: 37448; defer: 554; conflict: 774
  OInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 1603; closed: 37589; defer: 554; conflict: 774
  oInternal error: found 2 (choice -> promotion) mappings for a single choice.
open: 10794; closed: 44552; defer: 619; conflict: 877
  oNo solution found within the allotted time. Try harder? [Y/n] y
Resolving dependencies...
open: 23951; closed: 52255; defer: 619; conflict: 877
 oNo solution found within the allotted time. Try harder? [Y/n] y
Resolving dependencies...
open: 33838; closed: 166435; defer: 619; conflict: 877
  ONo solution found within the allotted time. Try harder? [Y/n] n
Abandoning all efforts to resolve these dependencies.
The following NEW packages will be installed:
  libasn1-8-heimdal:i386{a} libasound2:i386{a} libasound2-plugins:i386{a}
  libasyncns0:i386{a} libavahi-client3:i386{a} libavahi-common-data:i386{a}
  libavahi-common3:i386{a} libcapi20-3:i386{a} libcgmanager0:i386{ab}
  libcomerr2:i386{ab} libcups2:i386{a} libdb5.3:i386{a} libdbus-1-3:i386{a}
  libdrm-intel1:i386{ab} libdrm-nouveau2:i386{ab} libdrm-radeon1:i386{ab}
  libdrm2:i386{ab} libelf1:i386{a} libexif12:i386{a} libexpat1:i386{a}
  libffi6:i386{a} libflac8:i386{a} libfontconfig1:i386{a}
  libfreetype6:i386{ab} libgcrypt11:i386{a} libgd3:i386{a}
  libgl1-mesa-dri:i386{a} libgl1-mesa-glx:i386{a} libglapi-mesa:i386{a}
  libglu1-mesa:i386{a} libgnutls26:i386{a} libgpg-error0:i386{a}
  libgphoto2-6:i386{a} libgphoto2-port10:i386{a} libgsm1:i386{a}
  libgssapi-krb5-2:i386{ab} libgssapi3-heimdal:i386{a}
  libhcrypto4-heimdal:i386{a} libheimbase1-heimdal:i386{a}
  libheimntlm0-heimdal:i386{a} libhx509-5-heimdal:i386{a} libice6:i386{a}
  libieee1284-3:i386{a} libjack-jackd2-0:i386{a} libjbig0:i386{a}
  libjpeg-turbo8:i386{a} libjpeg8:i386{a} libjson-c2:i386{a}
  libk5crypto3:i386{ab} libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a}
  libkrb5-3:i386{ab} libkrb5support0:i386{ab} liblcms2-2:i386{a}
  libldap-2.4-2:i386{a} libllvm3.4:i386{a} libltdl7:i386{a}
  liblzma5:i386{a} libmpg123-0:i386{a} libnih-dbus1:i386{a} libnih1:i386{a}
  libodbc1:i386{a} libogg0:i386{a} libopenal1:i386{a} libosmesa6:i386{a}
  libp11-kit0:i386{a} libpcap0.8:i386{a} libpciaccess0:i386{a}
  libpng12-0:i386{a} libpulse0:i386{ab} libroken18-heimdal:i386{a}
  libsamplerate0:i386{a} libsane:i386{a} libsasl2-2:i386{a}
  libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} libsm6:i386{a}
  libsndfile1:i386{a} libspeexdsp1:i386{a} libsqlite3-0:i386{a}
  libssl1.0.0:i386{a} libtasn1-6:i386{a} libtiff5:i386{a}
  libtxc-dxtn-s2tc0:i386{a} libudev1:i386{ab} libusb-1.0-0:i386{a}
  libuuid1:i386{ab} libv4l-0:i386{a} libv4lconvert0:i386{a}
  libva-x11-1:i386{a} libva1:i386{a} libvorbis0a:i386{a}
  libvorbisenc2:i386{a} libvpx1:i386{a} libwind0-heimdal:i386{a}
  libwrap0:i386{a} libx11-6:i386{a} libx11-xcb1:i386{a} libxau6:i386{a}
  libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} libxcb-glx0:i386{a}
  libxcb-present0:i386{a} libxcb-sync1:i386{a} libxcb1:i386{a}
  libxcomposite1:i386{a} libxcursor1:i386{a} libxdamage1:i386{a}
  libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} libxi6:i386{a}
  libxinerama1:i386{a} libxml2:i386{a} libxpm4:i386{a} libxrandr2:i386{a}
  libxrender1:i386{a} libxshmfence1:i386{a} libxslt1.1:i386{a}
  libxt6:i386{a} libxxf86vm1:i386{a} wine-staging-i386:i386 zlib1g:i386{a}
0 packages upgraded, 123 newly installed, 0 to remove and 6 not upgraded.

Need to get 26,2 MB/46,1 MB of archives. After unpacking 259 MB will be used.
aptitude failed to find a solution to these dependencies. You can solve them yourself by hand or type 'n' to quit.
The following packages have unmet dependencies:
 libgssapi-krb5-2 : Breaks: libgssapi-krb5-2:i386 (!= 1.12+dfsg-2ubuntu5.1) but 1.12+dfsg-2ubuntu4.2 is to be installed.
 libgssapi-krb5-2:i386 : Breaks: libgssapi-krb5-2 (!= 1.12+dfsg-2ubuntu4.2) but 1.12+dfsg-2ubuntu5.1 is installed.
 libdrm-intel1 : Breaks: libdrm-intel1:i386 (!= 2.4.56-1~ubuntu2) but 2.4.56-1~ubuntu1 is to be installed.
 libdrm-intel1:i386 : Breaks: libdrm-intel1 (!= 2.4.56-1~ubuntu1) but 2.4.56-1~ubuntu2 is installed.
 libkrb5-3 : Breaks: libkrb5-3:i386 (!= 1.12+dfsg-2ubuntu5.1) but 1.12+dfsg-2ubuntu4.2 is to be installed.
 libkrb5-3:i386 : Breaks: libkrb5-3 (!= 1.12+dfsg-2ubuntu4.2) but 1.12+dfsg-2ubuntu5.1 is installed.
 libcomerr2 : Breaks: libcomerr2:i386 (!= 1.42.9-3ubuntu1.2) but 1.42.9-3ubuntu1 is to be installed.
 libcomerr2:i386 : Breaks: libcomerr2 (!= 1.42.9-3ubuntu1) but 1.42.9-3ubuntu1.2 is installed.
 libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.56-1~ubuntu2) but 2.4.56-1~ubuntu1 is to be installed.
 libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.56-1~ubuntu1) but 2.4.56-1~ubuntu2 is installed.
 libfreetype6 : Breaks: libfreetype6:i386 (!= 2.5.2-1ubuntu2.3) but 2.5.2-1ubuntu2.2 is to be installed.
 libfreetype6:i386 : Breaks: libfreetype6 (!= 2.5.2-1ubuntu2.2) but 2.5.2-1ubuntu2.3 is installed.
 libcgmanager0 : Breaks: libcgmanager0:i386 (!= 0.24-0ubuntu7.3) but 0.24-0ubuntu7.2 is to be installed.
 libcgmanager0:i386 : Breaks: libcgmanager0 (!= 0.24-0ubuntu7.2) but 0.24-0ubuntu7.3 is installed.
 libuuid1 : Breaks: libuuid1:i386 (!= 2.20.1-5.1ubuntu20.4) but 2.20.1-5.1ubuntu20.3 is to be installed.
 libuuid1:i386 : Breaks: libuuid1 (!= 2.20.1-5.1ubuntu20.3) but 2.20.1-5.1ubuntu20.4 is installed.
 libudev1 : Breaks: libudev1:i386 (!= 204-5ubuntu20.10) but 204-5ubuntu20.9 is to be installed.
 libudev1:i386 : Breaks: libudev1 (!= 204-5ubuntu20.9) but 204-5ubuntu20.10 is installed.
 libdrm-nouveau2 : Breaks: libdrm-nouveau2:i386 (!= 2.4.56-1~ubuntu2) but 2.4.56-1~ubuntu1 is to be installed.
 libdrm-nouveau2:i386 : Breaks: libdrm-nouveau2 (!= 2.4.56-1~ubuntu1) but 2.4.56-1~ubuntu2 is installed.
 libpulse0 : Breaks: libpulse0:i386 (!= 1:4.0-0ubuntu11.1) but 1:4.0-0ubuntu11 is to be installed.
 libpulse0:i386 : Breaks: libpulse0 (!= 1:4.0-0ubuntu11) but 1:4.0-0ubuntu11.1 is installed.
 libdrm2 : Breaks: libdrm2:i386 (!= 2.4.56-1~ubuntu2) but 2.4.56-1~ubuntu1 is to be installed.
 libdrm2:i386 : Breaks: libdrm2 (!= 2.4.56-1~ubuntu1) but 2.4.56-1~ubuntu2 is installed.
 libkrb5support0 : Breaks: libkrb5support0:i386 (!= 1.12+dfsg-2ubuntu5.1) but 1.12+dfsg-2ubuntu4.2 is to be installed.
 libkrb5support0:i386 : Breaks: libkrb5support0 (!= 1.12+dfsg-2ubuntu4.2) but 1.12+dfsg-2ubuntu5.1 is installed.
 libk5crypto3 : Breaks: libk5crypto3:i386 (!= 1.12+dfsg-2ubuntu5.1) but 1.12+dfsg-2ubuntu4.2 is to be installed.
 libk5crypto3:i386 : Breaks: libk5crypto3 (!= 1.12+dfsg-2ubuntu4.2) but 1.12+dfsg-2ubuntu5.1 is installed.
Resolve these dependencies by hand? [N/+/-/_/:/?] n
Abort.

Manfred Hampl (m-hampl) said : #7

What is the output of

sudo dpkg --audit
sudo apt-get dist-upgrade
apt-cache policy libgssapi-krb5-2 libgssapi-krb5-2:i386 libpulse0 libpulse0:i386 libdrm2 libdrm2:i386

Sven Pattyn (sven-pattyn) said : #8

Problem solved:

By going over the output of "apt-cache policy libgssapi-krb5-2 libgssapi-krb5-2:i386 libpulse0 libpulse0:i386 libdrm2 libdrm2:i386", I remembered that I had changed the download server of ubuntu some time ago (because it was going terribly slow, I could only download at 5-10 kb/sec). After restoring the original settings, I tried installing pipelight again and now it did so without the errors described above.

thanks for your support!

Goddard (kinggoddard) said : #9

I never changed my sources and I get this same error.

Wouter Van Eenoo (wouter205) said : #10

I got the same error on ubuntu 15.10 x64.

Just saved the server from 'server for Belgium' to 'Main server', but problem remains the same.

Please provide support.

Manfred Hampl (m-hampl) said : #11

@Wouter:
Please do not piggyback on somebody else's question, but create a question of your own.
The original question document is already in status "solved", and there is no possibility to track the status of your problem with that document.