Silverlight Video Very Dark

Asked by joes on 2015-02-04

Hi,

Hoping someone can shed some light (bad pun!) on this. Recently when I play Netflix all of the video appears very dark. It is as if someone changed the brightness and contrast down to the lowest setting. Note that the video does play just in this very dark state. See screenshot here:

https://www.dropbox.com/s/qfk6zj530u9ltb1/Netflix.jpg?dl=0

I have searched and tried what I have found but to no avail. I completely removed pipelight and re-installed, I installed Firefox instead of IceWeasel and tried it on that but it was the same.

Here is the output of --system-check (all looks OK I think).

http://pastebin.com/K3urQ2Nq

Also I tried the testing tool here and all three tests came back as OK.

All suggestions welcome to have it return to normal. Thanks.

Joes

Question information

Language:
English Edit question
Status:
Answered
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Last query:
2015-02-04
Last reply:
2015-02-05
Sebastian Lackner (slackner) said : #1

Please take a look here, I assume this issue is identical to the following bug report:
https://bugs.launchpad.net/pipelight/+bug/1415219

There was a wine change recently related to the d3d sampler code, which caused this weird behavier. You can either try to downgrade your Wine version, or alternatively try to upgrade Mesa, which also seems to solve the problem.

joes (joesken) said : #2

Thanks Sebastian - that sounds like it will solve it exactly.

I started with great enthusiasm trying to upgrade Mesa but ended up in a terrible mess of dependencies and backports which I really don't know enough to navigate my way through.

I went back then to downgrading wine but I am receiving the following error which I don't fully understand as with my reading of it it is asking for libpulse0 to be greater than version 0.9 but version 2.0 is installed (which is greater than it). Just a bit stumped if you can shed any light. It is really a pipelight problem anymore though so if not appropriate just let me know and I can maybe ask around elsewhere, thanks.

dpkg: warning: downgrading wine-staging from 1.7.35~ubuntu12.04.1 to 1.7.34-1~ubuntu12.04.1
(Reading database ... 177400 files and directories currently installed.)
Preparing to replace wine-staging 1.7.35~ubuntu12.04.1 (using wine-staging_1.7.34-1~ubuntu12.04.1_i386.deb) ...
Unpacking replacement wine-staging ...
dpkg: warning: downgrading wine-staging-i386 from 1.7.35~ubuntu12.04.1 to 1.7.34-1~ubuntu12.04.1
Preparing to replace wine-staging-i386 1.7.35~ubuntu12.04.1 (using wine-staging-i386_1.7.34-1~ubuntu12.04.1_i386.deb) ...
Unpacking replacement wine-staging-i386 ...
dpkg: dependency problems prevent configuration of wine-staging-i386:
 wine-staging-i386 depends on libpulse0 (>= 1:0.99.1); however:
  Version of libpulse0:i386 on system is 2.0-6.1.

dpkg: error processing wine-staging-i386 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine-staging:
 wine-staging depends on wine-staging-i386 (= 1.7.34-1~ubuntu12.04.1); however:
  Package wine-staging-i386 is not configured yet.

dpkg: error processing wine-staging (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 wine-staging-i386
 wine-staging

Joseph

Can you help with this problem?

Provide an answer of your own, or ask joes for more information if necessary.

To post a message you must log in.