Wine staging

Asked by monkeybrain2012 on 2015-01-11

Hi, today's wine compholio update from pipelight stable ppa pulled in wine staging and after than all pipelight plugins (unity3d, widevine and silverlight) failed to load. A popup leads to this page http://pipelight.net/cms/faqs/faq-pipelight-error-in-aboutplugins.html

Tried 'pipelight-plugin --update', 'pipelight-plugin --create-mozilla-plugins' as well as removing .wine-pipelight and re-enabling the plugins. None worked and strangely Firefox also started freezing randomly.

I have since reverted to the state (from a clone) before the update and everything is working perfectly again. OS is Ubuntu 14.0.4

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
monkeybrain2012
Solved:
2015-01-11
Last query:
2015-01-11
Last reply:
2015-01-11
Sebastian Lackner (slackner) said : #1

What happens when you start firefox from a terminal?

Could you please also show the output of

dpkg --list | grep wine

We are aware of a problem which causes trouble for users doing a fresh install of wine-staging/wine-compholio, but normally it should work fine when you just updated from a previous version.

Michael Müller (mqchael) said : #2

The Wine Compholio project changes its name to Wine Staging some time ago and we wanted to complete this change by renaming the wine package. This change also included moving the wine executable from /opt/wine-compholio/bin/wine to /opt/wine-staging/bin/wine. In order to provide backwards compatibility we made some wine-compholio packages which contains symlinks to the old files.

However, the wine-compholio package missed a dependency and therefore one of the compatibility packages was marked as no longer needed. If you removed this package it broke the pipelight installation. I just pushed a new pipelight package which directly depends on wine-staging and that contains the correct executable path. It does not need these compatibility packages and should solve the problem. Please upgrade to pipelight 0.2.8.1 and try again.

Michael

monkeybrain2012 (kammon101) said : #3

Hmmm..

Updated again (I have reverted the update when I posted the first) and this time I don't have any problem.
Sorry for the false alarm.

But I am posting the outputs of dpkg --list | grep wine anyway in case there is anything wrong

 dpkg --list | grep wine
ii wine-compholio 1.7.34~ubuntu14.04.1 amd64 Transitional dummy package
ii wine-compholio-amd64 1.7.34~ubuntu14.04.1 amd64 Transitional dummy package
ii wine-compholio-i386 1.7.34~ubuntu14.04.1 i386 Transitional dummy package
ii wine-gecko2.34:amd64 2.34-0ubuntu1~ppa1 amd64 Microsoft Windows compatibility layer (embedded web browser)
ii wine-gecko2.34:i386 2.34-0ubuntu1~ppa1 i386 Microsoft Windows compatibility layer (embedded web browser)
ii wine-mono4.5.4 4.5.4-0ubuntu1~ppa1 all Microsoft Windows compatibility layer (.NET compatibility)
ii wine-staging 1.7.34~ubuntu14.04.1 amd64 The Staging Edition is a special build of the popular Wine software
ii wine-staging-amd64 1.7.34~ubuntu14.04.1 amd64 The Staging Edition is a special build of the popular Wine software
ii wine-staging-i386 1.7.34~ubuntu14.04.1 i386 The Staging Edition is a special build of the popular Wine software
ii wine1.7 1:1.7.33-0ubuntu1~ppa1 amd64 Microsoft Windows Compatibility Layer (Binary Emulator and Library)
ii wine1.7-amd64 1:1.7.33-0ubuntu1~ppa1 amd64 Microsoft Windows Compatibility Layer (64-bit support)
ii wine1.7-i386 1:1.7.33-0ubuntu1~ppa1 i386 Microsoft Windows Compatibility Layer (32-bit support)
ii winetricks 0.0+20140302-0ubuntu2 all Microsoft Windows Compatibility Layer (winetricks)

Thanks and keep up the good work.

monkeybrain2012 (kammon101) said : #4

I should clarify that in post #3 I haven't yet upgraded pipelight to 0.2.8.1. Now I have, it is still working.