SkyGo error [t:6030 / c:4110]

Asked by sweetthdevil on 2014-11-19

Hello there,

Just install pipelight using AUR on Arch, I have it working using various test website and also http://fds-team.de/pipelight/. The Silverlight 5.1 test are all showing Okay.

However when attempting to watch SkyGo (the on-line version of Sky UK) I get the following error code [t:6030 / c:4110]

I use Firefox as Chromium require works to make it work, tried with several user agent, Windows IE 11,10,9 - Windows Forefox, Mac Firefox - the same error always appear.

Edit: I tried to test the video from http://web.sldrm.video.msn.com/d1/sldrm.html and the video never start neither.

Looking forward for your reply,

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
sweetthdevil
Solved:
2014-11-19
Last query:
2014-11-19
Last reply:
2014-11-19
Michael Müller (mqchael) said : #1

Hi,

as mentioned on http://pipelight.net/cms/plugin-silverlight.html SkyGO requires Silverlight 5.0 when being used with Pipelight. Microsoft increased the DRM checks in Silverlight 5.1 and silverlight applications need to manually disable them again, if they want to have the same protection like in Silverlight 5.0. Most websites do this, but the DRM test website you mentioned and SkyGO do not.

For legal reasons we can not support these new DRM checks.

The easiest workaround is simply to switch to Silverlight 5.0:
sudo pipelight-plugin --disable silverlight5.1 --enable silverlight5.0

Michael

sweetthdevil (sweetthdevil) said : #2

Hello,

thank you for your prompt reply, that solve the issue of the video not playing.

However the sound was delay, so I played with it - as the help page suggested and it now work like a charm!

Thank you for all your work!