wine-compholio not installed with pipelight under ubuntu 14.04 lts

Asked by martin carter on 2014-11-06

Following ubuntu instructions for pipelight installation fails at :

 sudo apt-get install --install-recommends pipelight-multi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 pipelight-multi : Depends: wine-compholio (>= 1.7.19-1~)
E: Unable to correct problems, you have held broken packages.

Software source is :
http://ppa.launchpad.net/pipelight/stable/ubuntu trusty main

Any help appreciated

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
martin carter
Solved:
2014-11-12
Last query:
2014-11-12
Last reply:
2014-11-08
Patrick Wüchner (pkwuechn) said : #1

I'm having the same problem on Ubuntu 14.04 and using ppa:pipelight/stable and was not able to find a viable solution yet.
I'm adding some more information, hoping that they might help to track the issue down.

Trying to install wine-compholio using aptitude mentions:
-- 8< --
user@host:~$ sudo aptitude install wine-compholio
The following NEW packages will be installed:
  liblcms2-2:i386{ab} wine-compholio wine-compholio-amd64{a} wine-compholio-i386:i386{a}
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 38.4 MB of archives. After unpacking 285 MB will be used.
The following packages have unmet dependencies:
 liblcms2-2 : Breaks: liblcms2-2:i386 (!= 2.6-3ubuntu1~precise1) but 2.5-0ubuntu4 is to be installed.
 liblcms2-2:i386 : Breaks: liblcms2-2 (!= 2.5-0ubuntu4) but 2.6-3ubuntu1~precise1 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) liblcms2-2:i386 [Not Installed]
2) wine-compholio [Not Installed]
3) wine-compholio-i386:i386 [Not Installed]
-- >8 --

Accepting the proposed actions does not solve the issue.

"sudo aptitude install liblcms2-2:i386" suggests an disproportionately long list of 349 packages to be removed.

Patrick Wüchner (pkwuechn) said : #2

This might not be the optimal solution, but it finally helped me to install Pipelight on Ubuntu 14.x.

Searching the Internet for the "liblcms2-2:i386 : Breaks: liblcms2-2" issue, I stumbled across https://bugs.launchpad.net/wine/+bug/1229221, which seems to be related. One solution suggested there is to upgrade from 14.04 to 14.10. I did that following https://wiki.ubuntu.com/UtopicUnicorn/ReleaseNotes#Upgrading_from_Ubuntu_14.04_LTS .

After upgrading to 14.10, I was able to install Pipelight successfully by following http://pipelight.net/cms/install/installation-ubuntu.html.

Michael Müller (mqchael) said : #3

Hi,

@martin carter: It would be great if you could post the output of:

sudo aptitude install pipelight-multi

since the apt-get does not provide a lot of information in case of dependency problems.

@Patrick Wüchner:

There was something wrong with your 14.04 setup:

 liblcms2-2 : Breaks: liblcms2-2:i386 (!= 2.6-3ubuntu1~precise1) but 2.5-0ubuntu4 is to be installed.
 liblcms2-2:i386 : Breaks: liblcms2-2 (!= 2.5-0ubuntu4) but 2.6-3ubuntu1~precise1 is installed.

There was some conflict between precise and trusty packages. If you would have upgraded the liblcms2-2 precise package to a trusty package, the dependency problem should no longer occur.

I also use 14.04 and there is no such problem if you do a fresh install.

Michael

martin carter (mkcarter) said : #4

Hi

@Patrick Wüchner: Many thanks.

martin@hp-workstation-xw8200:~$ sudo aptitude install pipelight-multi
The following NEW packages will be installed:
  libasound2-plugins:i386{a} libgsm1:i386{a} libjack-jackd2-0:i386{ab}
  libodbc1:i386{a} libpcap0.8:i386{a} libsamplerate0:i386{a}
  libspeexdsp1:i386{a} mesa-utils{a} pipelight-multi wine-compholio{a}
  wine-compholio-amd64{a} wine-compholio-i386:i386{a}
0 packages upgraded, 12 newly installed, 0 to remove and 379 not upgraded.
Need to get 40.5 MB of archives. After unpacking 292 MB will be used.
The following packages have unmet dependencies:
 libjack-jackd2-0:i386 : Conflicts: libjack-0.116 which is a virtual package.
                         Conflicts: libjack0 but 1:0.121.3+20120418git75e3e20b-2.1ubuntu1 is installed.
 libjack0 : Conflicts: libjack-0.116:i386 which is a virtual package.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) libasound2-plugins:i386 [Not Installed]
2) libjack-jackd2-0:i386 [Not Installed]
3) pipelight-multi [Not Installed]
4) wine-compholio [Not Installed]
5) wine-compholio-i386:i386 [Not Installed]

regards
Martin

martin carter (mkcarter) said : #5

Upgrade to 14.10 failed to fix the problem.

The following packages have unmet dependencies:
 libjack-jackd2-0:i386 : Conflicts: libjack-0.116 which is a virtual package.
                         Conflicts: libjack0 but 1:0.124.1+20140122git5013bed0-3 is installed.
 libjack0 : Conflicts: libjack-0.116:i386 which is a virtual package.

regards
martin

Victor (rvv-apt) said : #6

I have the same problem with Ubuntu 14.10 64bit.
It can't install the wine-compholio-i386 package because it isn't a part of binary-amd64 release, but it is listed on Depends for wine-compholio package along with wine-compholio-amd64.
For the binary-i386 release wine-compholio package depends only on wine-compholio-i386 and it is included in package list.
So, i suppose, this problem is for Ubuntu 64bit only.

Victor (rvv-apt) said : #7

I have solved my problem and finally installed Pipelight.
On 64bit Ubuntu you must add possibility to install i386 packages with following commands:

sudo dpkg --add-architecture i386
sudo apt-get update

Michael Müller (mqchael) said : #8

Adding the i386 architecture explicitly is only necessary if you are not running a normal Ubuntu installation like the Ubuntu cloud image or Ubuntu Server. The normal Ubuntu installation has the i386 multiarch option enabled by default.

martin carter (mkcarter) said : #9

The command
> sudo dpkg --add-architecture i386
made no difference to my problem.

I have the same AMD64 architecture on another machine and pipeline installs OK there under 14.04 ??

From what I can see on internet it may have something to do with ia32-libs and googleearth (though this no longer seems to be installed on my errant machine).

Martin

martin carter (mkcarter) said : #10

Hi

Removing package libjack0 with

> sudo apt-get remove libjack0

> sudo apt-get autoremove

> sudo apt-get update

allows the pipelight package to install.

Not sure what else I may have affected by uninstalling libjack0 but assume they would have been flagged by update ?

many thanks
Martin

Enrico Mattea (ocirne94) said : #11

Same problem here (Ubuntu 14.04 64-bit):

$ sudo aptitude install pipelight-multi

I seguenti pacchetti NUOVI (NEW) saranno installati:
  pipelight-multi ttf-mscorefonts-installer{a} wine-compholio{ab}

0 pacchetti aggiornati, 3 installati, 0 da rimuovere e 0 non aggiornati.

È necessario prelevare 3.297 kB di archivi. Dopo l'estrazione, verranno occupati 14,8 MB.

I seguenti pacchetti hanno dipendenze non soddisfatte:

 wine-compholio : Dipende: wine-compholio-i386 (= 1.7.31~ubuntu14.04.1) che è un pacchetto virtuale.
Le seguenti azioni permetteranno di soddisfare queste dipendenze:

     Mantenere i seguenti pacchetti alla versione attuale:
1) pipelight-multi [Non installato]
2) wine-compholio [Non installato]

Really no solutions apart from upgrading?

I had the same problem but I think it's related to a not updated system or "wrong" installation.
By the way I had re-installed my OS and I fully updated it.
I hadn't the issue anymore.