Netflix HD stopped working

Asked by Fink Nottle on 2014-10-30

Hardware: Lenovo Thinkpad W530 (Nvidia Quadro K200M)
OS: Ubuntu 14.04
pipelnine version: Pipelight 0.2.7.1~ubuntu14.04.1
Silverlight version: 5.1.30514.0
nvidia-driver version: 331.38
firefox version: 33.0

Netflix HD stopped working for me sometime last week. It used to wok earlier. I don't see the HD icon, and I can't select a bitrate higher than 1750 in the silverlight ctrl+alt+shift+S settings. I suspect this is related to hardware acceleration (unless Netflix has disabled HD recently for linux the way other websites do citing HDCP). PIPELIGHT_GPUACCELERATION=1 firefox doesn't solve it and neither does overwriteArg = enableGPUAcceleration=true. Is there a way to check if hardware acceleration is working for silverlight ? The silverlight control panel shows it as greyed out, but that is probably a different issue.

Pipelight system check output (stdout+stderr) : http://pastebin.com/ax5Xy6Gq
Pipelight system check output (stderr only) : http://pastebin.com/7eMCuuZB

Edit: I have a feeling that this is something specific to do with netflix. Amazon prime plays HD fine using silverlight at a bitrate of 6Mbps

Question information

Language:
English Edit question
Status:
Answered
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Last query:
2014-11-01
Last reply:
2014-11-02
wheely (wheely75) said : #1

I have since last week the same problem with the HD-icon and the low bitrate . Suddenly it was gone .
I have also tried this already : PIPELIGHT_GPUACCELERATION=1 firefox , overwriteArg = enableGPUAcceleration=true , reinstall wine and pipelight.
All this has brought nothing.

Michael Müller (mqchael) said : #2

Hi,

I just tried it myself and the HD icon is still there for videos available in HD. I compared it to the HTML 5 version and I couldn't see any difference. Here is a screenshot of my test: https://dl.dropboxusercontent.com/u/61413222/netflix-hd.png

I am not aware of any changes in Wine which could cause this issue and Pipelight didn't get a new release for some time (though we are currently working on one). Maybe it is related to your ISP and Netflix does not show the icon if the connection is too bad?

I doubt that is something to do with HDCP otherwise they would have used the same check in the german version of netflix (which i used for my test). However, if you post a log of using netflix with pipelight (see http://pipelight.net/cms/faqs/faq-how-to-capture-debug-output.html ) I can tell you for sure if this could cause the problem.

Michael

wheely (wheely75) said : #3

pipelight.log

(process:5081): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(process:5173): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
pipelight-d3d.log

(process:5242): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

Michael Müller (mqchael) said : #4

You did not close all browser windows or did not use the plugin, there is no debug output of pipelight.

Fink Nottle (finknottle) said : #5

I don't think this is related to the ISP or the internet bandwidth. I can play HD if I boot into windows on the same machine and the same connection. Actually, the internet bandwidth only affects the automatically selected bitrate. You can always override it manually in silverlight's menu. In this case though, I don't see any bitrates higher than 1750 in the dropdown menu. Oddly enough, this affects HTML5 on linux too. That makes me think that it is a netflix specific issue.

pipelight log: http://pastebin.com/tSAM87pH

Linux+silverlight: http://www.imagebam.com/image/bd692c361566428
Linux+HTML5: http://www.imagebam.com/image/170331361566430

Windows+HTML5: http://www.imagebam.com/image/5538f4361567792
Windows+silverlight: http://www.imagebam.com/image/c84039361567797

wheely (wheely75) said : #6
Michael Müller (mqchael) said : #7

Hi,

I just verified your theory and it is correct. Netflix requires output protection for some Videos and falls back to SD quality if it is not available. The HTML5 player always falls back to SD quality since there is no output protection. The same happens with amazon instant.

This problem is therefore a duplicate of the 6030 bug.

Michael

Fink Nottle (finknottle) said : #8

This is pretty bad news. I can't find a single video that plays with HD on Netflix. So it looks like a site wide thing. You are probably not seeing this on the German site because either a) EU has different laws and protections for end users when it comes to content distribution b) It's just a matter of time before this gets rolled out to all international Netflix sites too. Your comments about 'always SD' in HTML5 are also rather unsettling. It would appear that all the hue and cry over DRM in HTML5 doesn't really matter. It does little to offer true cross platform compatibility. It's just another flash/silverlight replacement with ratification in the standard.

Michael Müller (mqchael) said : #9

Well, if you ask me the HTML5 DRM is making it even worse than now. At the moment we have browser plugins like Silverlight or Flash which uses a standard API which is supported by almost all browsers (except chrome since they want to push their own API).

The HTML5 DRM specification only defines a set of javascript commands and a plaintext key exchange system but the browser vendors can extend this systems with their own DRM stuff. Since nobody is going to use this plaintext key system which is completely insecure, all browsers are creating their own solutions. So what does this mean? Microsoft uses PlayReady in their browser, Google has now a builtin widevine plugin and Firefox is going to use something from adobe. The result is that instead of using a single plugin which works in all browsers, all VoD services need to add support for every single browser and this is not going to be easy. The video files on their servers are encrypted and they either need to find a way that that all licensing systems return the same key or they need to provide multiple encrypted video files. In both ways it will cost more money to support more systems and I can already imagine that you will need to use different browsers for different VoD services.

The HTMl5 DRM system is also more insecure from a content providers point of view and I wouldn't be surprised if they are going to increase the control of these content decryption modules (CDMs). They already achieved their first step by getting open source browsers like firefox to ship proprietary code.

Michael

Can you help with this problem?

Provide an answer of your own, or ask Fink Nottle for more information if necessary.

To post a message you must log in.