Unity tries to download instead of playing.

Asked by Michael Lulay on 2014-07-13

Hello!

I'm running LXLE (a lightweight version of Lubuntu) and I'm trying to play a game on Facebook that uses Unity Web Player. I've installed Pipelight and Wine, then installed and enabled the Unity plugin. I installed the User Agent Switcher on Chrome, as well, and configured Chrome 31 (I've tried in the preset Safari OSX and Firefox 15 agents, too). However, when I go to a Unity game (I've tested with a few), it tries to download the UnityWebPlayer.exe file and asks it to be installed instead of playing the game like it should.

I've spent probably an hour looking through articles and troubleshooting, but I can't find where anyone else has had this issue and I cannot figure out why this is happening. Let me know if you need more information!

Thank you for your time!
Michael

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
Sebastian Lackner
Solved:
2014-07-13
Last query:
2014-07-13
Last reply:
2014-07-13
Best Sebastian Lackner (slackner) said : #1

Hi,

this sounds like you're using a version of Chrome >= 35, where NPAPI (the plugin interface used by Pipelight) is deprecated.
New versions of Chrome (and also Chromium) only continue to support Googles own plugins. These recent changes are not reflected on the Pipelight.net site yet.

Please take a look at the linked bug report for more information.

Depending on the effort you want to spend to fix this, you could compile Chromium yourself, and apply this set of patches, to renable )(partial) NPAPI functionally (see: http://pipelight.net/cms/chrome-chromium.html ). A way easier solution is to just use a different browser like Firebox, Midori, Uzbl, Safari, ... or any of the other browsers with NPAPI support. Please note that you'll need to install/configure the user agent for each browser you're using in combination with Pipelight.

Please report back if this solves the issue.

Regards,
Sebastian

Michael Lulay (guardian1239) said : #2

Thank you for such a speedy and thorough response! :) I took the easy route and went through the steps to configure Firefox with the user agent and it's working now. Your help was very much appreciated!

Michael Lulay (guardian1239) said : #3

Thanks Sebastian Lackner, that solved my question.