Public key for wine-capi-1.7.19-3.1.i686.rpm is not installed

Asked by Chris Olin

warning: /var/cache/yum/x86_64/20/home_DarkPlayer_Pipelight/packages/wine-capi-1.7.19-3.1.i686.rpm: Header V3 RSA/SHA1 Signature, key ID caa5dfc8: NOKEY
Public key for wine-capi-1.7.19-3.1.i686.rpm is not installed
wine-capi-1.7.19-3.1.i686.rpm | 48 kB 00:01
Retrieving key from

GPG key retrieval failed: [Errno 14] HTTP Error 403 - Forbidden

Any advice on how to:
a). find and download this key (caa5dfc8), and
b). import it into whatever keyring yum uses

Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Solved by:
Chris Olin
Last query:
Last reply:
Revision history for this message
Michael Müller (mqchael) said :


could you simply retry the installation? The problem is caused by the openSUSE build servers. They mirror the files to many different servers around the globe to minimize the download times, but the system does not seem to work reliable in the last time. We already had several people who were redirected to mirrors which either have an outdated version of a file or like in your case the file was not mirrored at all.

Sadly we can not do so much about this. I tried to mirror the files to our own servers, but none of the mirrors seems to have all our files and the master server is access restricted and only registered mirrors are allowed to sync against it.

I found a mirror which contains the files for fedora but it is completely outdated, so it won't help you either.


Revision history for this message
Chris Olin (chris.olin) said :

Tried again, same result.

The commands found on to set the repository up in Fedora are pasted below:

sudo wget -O /etc/yum.repos.d/pipelight.repo
sudo yum install pipelight
sudo pipelight-plugin --update

You mentioned that there are other mirrors, but all I'm configured to use is the Fedora mirror hosted on OpenSUSE.

Revision history for this message
Chris Olin (chris.olin) said :

After poking at this for a little bit, I was able to come up with a resolution.

Strangely enough, the repository can be accessed at without issue. You'd think with the 403 Forbidden error, this wouldn't be possible. I was able to find the repomd.xml.key file in the repodata/ directory.

Copying the link to repomd.xml.key, I used wget to download the file to my computer (again, without issue), and then:

# rpm --import /path/to/keyfile

to import the keyfile. Subsequently, I ran:

~ rpm -qi gpg-pubkey-caa5dfc8

to make sure the key was imported successfully. Next, I re-ran:

sudo yum install pipelight

It made it past the integrity checks and is now installing all of the downloaded packages.

I have no idea why I was receiving the 403 Forbidden error when I was able to manually download they key file without issue, but I can mark this as solved now.

Revision history for this message
Sebastian Lackner (slackner) said :

Do you probably have installed any additional plugins or maybe caches/proxys/... inbetween? If yes then most likely the error is related to that.

Nevertheless I'm glad that you solved the issue. :)