no netflix video after upgrading to pipelight 0.2.7

Asked by monkeybrain2012


After upgrading to pipelight 0.2.7 netflix stops working on one of my machines. The page would not load but the audio would play, sometimes I would see a blackscreen, sometime it just stuck in the catelogue (where you pick the video, whatever it is called) , if I click a video the page would not refresh, but the audio would play in the background.

The video card is ati hd6300 with the open source driver. OS is Ubuntu 14.04. Before the latest update it was working fine. Then I remember reading somewhere that vpipelight 0.2.7 enables hardware acceleration for amd card sby default, it turned out to be the problem

Now it works again after I have disabled hardware acceleration following the instructions here

This is not so much a question because I have figured out the solution, yet I am not sure if it is a bug or a feature, so not sure whether to file a bug report or not. I am not sure how well it works with other AMD cards or drivers combination, but just want to report my experience here.


Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Michael Müller (mqchael) said :


I think your problem is not really caused by hardware acceleration itself. You most probably do not have libXcomposite installed on this machine or you turned of compositing, which is required for gpu acceleration to work when embedding is enabled. I would suggest you to to revert your changes and start your browser from a terminal with:


You get an extra window now and you should check whether it works in this case. I would recommend that you show us the output of "pipelight-plugin --check-system" and take a look at your Xorg log and search for compositing (whether it is enabled or disabled).


Revision history for this message
monkeybrain2012 (kammon101) said :


Output for "pipelight-plugin --check-system" is "unknown argument --check-system" But libXcomposite is already installed and since UI is Unity I am pretty sure that compositing is on and working.

With PIPELIGHT_EMBED=0 firefox there is an extra window but it is all black.

Revision history for this message
Michael Müller (mqchael) said :


sorry I meant "pipelight-plugin --system-check".


Revision history for this message
monkeybrain2012 (kammon101) said :


Here is the ouput for pipelight-plugin --system-check

Also, without disabling hw acceleration silverlight does not work on
 either, again no video, just audio.

Revision history for this message
monkeybrain2012 (kammon101) said :

Still no word?

Revision history for this message
Sebastian Lackner (slackner) said :


Sorry for the late reply, but I don't see anything critical in the system-check file above. Does:


help? (I wouldn't really expect it, but its probably worth a try.)

The output of


could probably also be useful to figure out what goes wrong.

When compositing isn't disabled, the only explanation which is left is, that it must be some driver specific issue. I'm not sure which version of mesa is distributed with Ubuntu 14.04 - but sometimes it helps to upgrade to a newer version (see: ). Nevertheless you would have to do this on your own risk - upgrading drivers always can lead to unexpected issues.


Can you help with this problem?

Provide an answer of your own, or ask monkeybrain2012 for more information if necessary.

To post a message you must log in.