Persisting "Downloading wine-silverlight5.1-installer" at boot

Asked by Ingemar Majholm

Running Linux Mint Debian Xfce jessie/sid, kernel 3.2.0-4-amd64, on a Dell Inspiron 9400 laptop, using Firefox, Swedish version 29.0

Installed Pipelight and Silverlight as root today after a fresh system update. Persisting problems with no sound and boot crashes with kernel 3.11-2-amd64 made me revert to 3.2.0-4-amd64. (With the newer kernel, sound never worked with Silverlight, but at first it worked with other programs. After about one hour sound ceased to work in all programs).

Now with 3.2.0-4-amd64 everything is working just fine, except at boot time when the message "Downloading wine-silverlight5.1-installer" always appears. The download is apparently also taking place, slowing down the boot process well over a minute.

Can't believe that the installer has to be downloaded more than once, during the install process. Has it failed to be permanently installed, or what?

Tried the solution of Question #248227, to:

sudo pipelight-plugin --disable-all

and now execute "sudo pipelight-plugin --enable silverlight"

Remark: In this case WITH sudo to make it accessible to all users.

The thing just happens the same way anyway.

Am I wrong - is this the way it's supposed to be???

Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Solved by:
Ingemar Majholm
Last query:
Last reply:
Revision history for this message
Sebastian Lackner (slackner) said :


I assume that this is the same problem as described in bug:

MDM uses Webkit to render the login screen, and the developers forgot to disable loading plugins. This means the login screen will try to load ALL installed plugins, not only specific to Pipelight (Linux Flash, Java, Moonlight, ...). The problem is that installing the Pipelight plugin doesn't succeed, because the login screen runs as user MDM with a home directory owned by root - wine doesn't allow such a combination for the wine prefix. This has the effect that the download/installation is repeated on every startup ...

For a final solution we will have to wait for a response for the corresponding upstream bug:

If you don't care about a bit slower startup, you can use:
sudo pipelight-plugin --update
to get a workaround, which will stop Pipelight from showing dialogs on the login screen (but will still load it, Pipelight cannot distinguish between a regular webbrowser and Webkit from the login screen).

The only reliable way to stop loading it, is to enable it for each user individually, instead of system-wide:

root$ sudo pipelight-plugin --disable-all
user$ pipelight-plugin --enable ...


Revision history for this message
Ingemar Majholm (i-majholm) said :

Thanks Sebastian,

I disabled the Silverlight plugin for the root and enabled it for all users instead, and this solved the problem.

With best regards,

Revision history for this message
David Tambascio (dtambascio) said :

Was having this issue also on a new install of Linux Mint 17, but the work around is good enough since I am the only one using my laptop in Linux. Thanks Sebastian!!!