Cannot disable pipelight flash

Asked by monkeybrain2012


I have installed pipelight flash and switch between it and system flash on Firefox. I always default to system flash and only use pipelight-flash on websites where 11.2 doesn't work. But I have noticed that since yesterday's pipelight update I have been stuck with pipelight-flash without being able to switch back.

I run sudo update-alternatives --config mozilla-flashplugin and make sure that system flash is the default. I clear all cookies and cache and restart Firefox, I reboot .. but whenever I load a flash page it is always pipelight-flash.

Even after running "pipelight-plugin --disable flash" and the terminal outputs say that pipelight flash has been disabled, when I restart firefox and pipelight flash still loads!?

This is rather strange, I have no intention of removing pipelight-flash and it has been working quite well, but there are some advantages in running native flash when it works so I still want to be able to switch between them.


Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
monkeybrain2012 (kammon101) said :

Forgot to mention, this is Ubuntu 13.10

Revision history for this message
Sebastian Lackner (slackner) said :


in our latest version 0.2.7 we have fixed a problem, that Firefox didn't use the right version, when multiple flash plugins are installed. This had the effect, that even though Pipelight Flash has a greater version number, Firefox did not use it unless you disable all other flash plugins. As this is fixed now Firefox will always use the latest version (which is activated). I assume that this is the reason why it suddenly behaves different. Disabling it should still be possible of course.

Could you please check again, that you have neither enabled plugins system-wide (with sudo) or for your user-account (without sudo)?

sudo pipelight-plugin --disable flash
pipelight-plugin --disable flash

If the problem is still there afterwards, please manually take a look at all the plugins listed in:

ls -al /usr/lib/mozilla/plugins

Is there maybe an additional symlink to pipelight flash somewhere?


Revision history for this message
monkeybrain2012 (kammon101) said :


I am able to disable pipelight-flash with sudo (so I must have enabled it system wide somehow, though I can't remember). But I am still unable to set alternatives.

Here is what I did:

Disable pipelight flash system wide, disable pipelight flash for my user (running 'pipelight-plugin --disable flash' twice with and without sudo) restart browser, check that flash 11.2 is being used. So far, good.

Close browser, re-enable flash for my user (pipelight-plugin --enable flash) Check that system flash is set to default with
sudo update-alternatives --config mozilla-flashplugin

Start Firefox, load flash, right click the video to show version, it is again flash 13 from pipelight.

The only flash entry from ls -al /usr/lib/mozilla/plugins is
lrwxrwxrwx 1 root root 37 Dec 11 22:05 -> /etc/alternatives/mozilla-flashplugin

Revision history for this message
Michael Müller (mqchael) said :


if you want to use the alternative system approach, you must not enable the plugin through the pipelight-plugin script any more. Simply add an alternative entry for /usr/lib/pipelight/ and enable it (the pipelight-plugin script also only adds a symlink).

Nevertheless, you do not need to use the alternative system approach any more. Simply select the linux npapi version in the alternative system and enable Pipelight flash through the pipelight-plugin script whenever you need it. Firefox will automatically take the most recent version (i.e Pipelight flash if it is enabled or the linux flash version). If you only want to change this for the current user, you do not even need to have root rights for this.


Revision history for this message
monkeybrain2012 (kammon101) said :

I am sorry, I am getting a bit confused.

Are you saying that instead of using update-alternatives I shoukd just do "pipelight-plugin --disabe/enable flash"?

Revision history for this message
Michael Müller (mqchael) said :

Yes, this should work too. I think this method is easier than messing around with the alternative system. Anyway, you can still use it, but you just must not enable Pipelight Flash through multiple ways.

Revision history for this message
monkeybrain2012 (kammon101) said :

Ok, I have tried both ways and they work.

To summarize, either
1) use pipelight-plugin --disable/enable flash to switch and forget the update-alternatives system
2)Run "pipelight-plugin --disable flash" and keep it disabled and use update-alternatives to switch just like before

Am I correct?

Revision history for this message
Michael Müller (mqchael) said :

Yes, this is correct.

Revision history for this message
monkeybrain2012 (kammon101) said :

And Just to clarify one more thing.

 In a new install if I go route 2) instead of enabling flash with "pipelight-plugin --enable" I would just set up update-alternatives to /usr/lib/pipelight/ (or whatever the correct path is)?

Update will still take place normally?

Revision history for this message
Michael Müller (mqchael) said :

Updates will always replace the original library /usr/lib/pipelight/, so that there is no difference between using the alternative system or the pipelight-plugin script. Both methods are equivalent, they are just a different way of telling the browser to use the plugin.

Revision history for this message
monkeybrain2012 (kammon101) said :

Thanks, that solves my problem.