Pipelight won't work even after reinstall on 14.04

Asked by Rudhra Raveendran

On both my new htpc that I built today and my laptop that's been running ubuntu for a while, Pipelight won't work. I tried deleting the .wine-pipelight folder and opening a browser to have it re download it, but it Netflix still wouldn't work and the folder didn't come back. I removed pipelight and pipelight-multi (I'm not sure why I had both), then I followed the installation instructions exactly, even removed the old ppa's first. Then I went and enabled silverlight, and command line said that it was enabled, but netflix and every silverlight site still won't work, telling my to install silverlight. What's going on?

Both the HTPC and laptop are running ubuntu 14.04, using GNOME desktop, and have AMD APUs.

Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Solved by:
Rudhra Raveendran
Last query:
Last reply:
Revision history for this message
Sebastian Lackner (slackner) said :

I assume you're trying to use Google Chrome or Chromium, is this right?

Revision history for this message
Rudhra Raveendran (rudytheninja) said :

On chromium, yes

Revision history for this message
Rudhra Raveendran (rudytheninja) said :

Oh but I forgot to mention, I tried firefox and it still won't work. Both browsers send me to the page that says what is the required system specifications to use netflix. I then tried a user agent switcher, that got me as far as loading the video player, then getting a message to install pipelight. The Team FSD pipelight checker also says that pipelight isn't installed properly, but no errors arose during installation of pipelight.

Revision history for this message
Sebastian Lackner (slackner) said :


please take a look at the linked bug reports, especially:

The problem you experience is no bug in Pipelight, it is caused by the fact that Chrome/Chromium has removed NPAPI support - this is the plugin interface used by almost all plugins (including Pipelight and Silverlight).

Basically this means, that Chrome/Chromium will only work with Chromes own plugins (like PepperFlash), but with none of the "older" plugins, like the regular Linux Flash Plugin, Moonlight, ... The Chrome developers are planning to do the same step on Windows till the end of the year, which makes Chrome basically completely unuseable for video-on-demand streaming which still require the Silverlight plugin.

As a workaround you can either:
a) Downgrade to an older version of Chromium or Google-Chrome. For links to old versions of Google-Chrome you can also take a look at the bug report above.
b) Use a different browser, for example Firefox or Iceweasel
c) Compile a patched version of Chromium with NPAPI support added again - since this can be very complicated, especially for unexperienced users, we will most likely start offering a separate PPA soon.


Revision history for this message
Sebastian Lackner (slackner) said :

Concerning the problems with firefox: Did you make sure that Silverlight is enabled? This was still enabled by default in "pipelight", but "pipelight-multi" doesn't do this automatically anymore, since we also support a lot other plugins (Flash/Unity3D/...).

To enable Silverlight just run:

sudo pipelight-plugin --enable silverlight

To set your user agent please take a look at the following FAQ:


Revision history for this message
Rudhra Raveendran (rudytheninja) said :

So for anyone else who had my same problems (pipelight not working on chromium on amd cpu (apu in my case) computer) this is what fixed it (And major thanks to Slackner and DarkPlayer on the pipelight irc for helping me get here!)

First I uninstalled all pipelight versions that I had. I then re-installed following the official instructions, and then I enabled silverlight. If you're using firefox, grab the user agent switcher here: https://addons.mozilla.org/en-US/firefox/addon/user-agent-overrider/

then go into its preferences and add these two lines at the end:
Firefox 15/Windows: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1
Safari/OSX: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/534.55.3 (KHTML, like Gecko) Version/5.1.3 Safari/534.53.10

If you want to use chrome, you'll have to download, follow this link and scroll to bottom (64 bit only im afraid):

Then you should be able to watch silverlight applications.

If the HD button won't show for netflix, it's because gpu acceleration is off. Close your browsers, then run this in your command line (ubuntu):
wget -O ~/.config/pipelight-silverlight5.1 https://dl.dropboxusercontent.com/u/61413222/pipelight-silverlight5.1

This runs pipelight with gpu acceleration every time. (Give your thanks to DarkPlayer!)

Now you should be able to watch silverlight stuff and have the HD button in netflix.

Again, many thanks to Slackner and DarkPlayer for helping out! Best devs ever!