Pipelight plugin doesn't show up or work

Asked by Joseph Becar on 2014-05-21

Installed Pipelight 0.2.6~ubuntu14.04.1, set up the User Agent Switcher stuff, and netflix-desktop seems to work, but for some reason, I can't get it to work in my chrome browser. All silverlight sites ask me to install silverlight. The test sites for silverlight give the same prompt.

When I execute sudo pipeight-plugin --list-enabled

I get:

silverlight5.1
widevine

So I know it's enabled. I've tried re-installing and deleting the ~/.wine-pipelight folder and restarting the browser, but I haven't been able to figure out what's wrong.

Am I missing something?

Question information

Language:
English Edit question
Status:
Answered
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Last query:
2014-05-21
Last reply:
2014-05-21
Sebastian Lackner (slackner) said : #1

Hi,

you most probably missed the release of Chrome v35 a few hours ago. This release removed the complete NPAPI plugin interface, so its not possible to use any other plugins (besides the integrated PepperFlash one) anymore.

[ Bug #1307989 also contains some patches which can be used to add back this feature (but without embedding). Nevertheless compiling chromium yourself is difficult, so this is nothing which can be done in a few minutes. But maybe the Ubuntu developers will pick it up there, and include it in their builds... ]

Currently we recommend either to use an old version of Chrome/Chromium (< 35) or alternatively to use some other browser like Firefox, Opera, Uzbl, ...

Regards,
Sebastian

Can you help with this problem?

Provide an answer of your own, or ask Joseph Becar for more information if necessary.

To post a message you must log in.