problem with czech characters

Asked by michal

Hi all,
I am desperate. I have switched from Windows to Linux and everything is perfect. We have one important application in Silverlight, so I was so happy, that I found Pipelight!
But I found one problem. I can not write some characters in my keyboard (czech), č,ě,ř
I tried everything, keyboards setting, browsers etc. This problem is only in Silverlight (Pipelight) aplication.
do you have any ideas, please?


Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was reopened

Revision history for this message
Michael Müller (mqchael) said :


sorry for the late answer, but i am currently a bit busy. Can you describe what happens if you try to enter such a character? I do not have a czech keyboard layout but already copying the characters into a silverlight text box splits the characters into multiple ones. Is the character simply skipped when entering it, does it show the wrong character or even multiple ones?


Revision history for this message
michal (michal-strnad) said :

Hi Michael,
many thanks for your reply. You do amazing job.
I found, that there is a different in each linux dist.

In LINUX MINT (16 Petra)
if I wrote č,ě,ř,ů on my keyboard, it is showin c,e,r,u
Other czech characters are ok (like šžýáíéŠ,Ž)

I have tried on fresh instalation of new Xubuntu (Xubuntu 14.04 'Trusty Tahr') and everything works, but not woking capital czech characters like Š,Ž, :-)

So, I it is difficult find where the problem is.

I use Firefox browser.


Revision history for this message
michal (michal-strnad) said :

Hi Michael,
I found a solution. Lubuntu, there everything works. I dont understand why, but it works :-)

Revision history for this message
Sebastian Lackner (slackner) said :

Hi Michal,

can you maybe check what the environment variable "LANG" contains on both systems (if you still have access to both of them)?
For example just:

echo "$LANG"

I would suspect that Lubuntu uses a different value than your other machine, and that this is the reason for the different behaviour.

BTW: If you can also reproduce this problem with vanilla wine + some other applications (you could for example use a simple text editor for testing), it probably also makes sense to open a bug report there - at least if noone else has reported this issue yet.


Revision history for this message
Michael Müller (mqchael) said :


You can reproduce the issue with

LANG=cs_CZ.UTF-8 /opt/wine-compholio/bin/wine notepad.exe

Just try to copy the characters from the first post into notepad.

It seems to work better by using this locale settings:

LANG=cs_CZ ISO-8859-2 /opt/wine-compholio/bin/wine notepad.exe

Don't forget to generate those locales first, otherwise it will fallback to english. You can enable the locales by adding the following entries to /var/lib/locales/supported.d/local:

cs_CZ.UTF-8 UTF-8
cs_CZ.ISO-8859-2 ISO-8859-2

and running: sudo dpkg-reconfigure locales


Revision history for this message
michal (michal-strnad) said :

Hi Michael and Sebastian,
thanks for your reply. I am so sorry, but I am Linux beginner, so I dont know what you exactly mean.
If I put echo "$LANG" to the Terminal, I got:

then I added
cs_CZ.ISO-8859-2 ISO-8859-2
to the: /var/lib/locales/supported.d/local:

and made
sudo dpkg-reconfigure locales

but witout changes. the problem on Mint is still.

Revision history for this message
Michael Müller (mqchael) said :

Hi Michal,

close all your browser windows and start your browser from a terminal in the following way:

LANG=cs_CZ.ISO-8859-2 firefox

and check whether the problem is gone.


Revision history for this message
michal (michal-strnad) said :

Ohh. it WORKS!!!!!!
many many thanks Michael !