Pipelight on CentOS ? Loads but won't show content

Asked by Andrew Daviel

I am trying to view some Sonic Foundry Mediasite 6 content, which needs Silverlight 5 (better than Moonlight, anyway).

I have CentOS 5 and CentOS 6 (currently the latest RedHat enterprise) x86_64 systems, with Firefox 24.3 and Chrome 25.0.1364.97

I installed wine-1.7.11 from the Darkplayer CentOS 6 repository.

I installed the pipelight- from the Darkplayer Fedora 18 repository, but it failed with "GLIBC_2.15' not found (required by /usr/lib/pipelight/libpipelight-silverlight5.1.so)"

I tried to build pipelight from SRPM from the Fedora 18 repository, but as published it failed with i686-w64-mingw32-g++ not found. I changed that, but had further mingw32 errors.

I then downloaded pluginloader.exe and modified the spec file to build with --win32-prebuilt. That ran successfully and
made me a good RPM, which I installed.
I ran pipelight-plugin --enable silverlight and --enable flash, which apparently worked. In Firefox about:plugins, I see
libpipelight-flash.so and libpipelight-silverlight5.0.so. Flash appears to work in pipelight for youtube.

The bubblemark animation loads, but does not run. I can right-click and see the info boxes. Silverlight shows version 5.0.61118.0

Mediasite recognizes the plugin and loads the page, but the video does not run.
Other sites e.g. http://demos.devexpress.com/democenter/Silverlight/ the same.

On the command line launching firefox, I see e.g.
[PIPELIGHT:WIN:silverlight5.1] init successful!
[PIPELIGHT:LIN:silverlight5.1] nppfunctions.c:436:NPP_New(): malformed argument 'PARAM' -> '(null)'
fixme:advapi:CreateProcessAsUserW 0xec L"C:\\Program Files\\Silverlight\\5.1.20913.0\\agcp.exe" L"agcp.exe 64 228" (nil) (nil) 1 0x00004000 (nil) (null) 0x66f1b8 0x66f1a8 - semi-stub

In Chrome I see a similar thing - the bubblemark animation does not run but I see the info box.
On the command line I see
[PIPELIGHT:WIN:silverlight5.1] init successful!
[PIPELIGHT:LIN:silverlight5.1] using timer based event handling.
fixme:advapi:CreateProcessAsUserW 0xec L"C:\\Program Files\\Silverlight\\5.1.20913.0\\agcp.exe" L"agcp.exe 62 228" (nil) (nil) 1 0x00004000 (nil) (null) 0x66f1b8 0x66f1a8 - semi-stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:file:K32GetMappedFileNameW (0xffffffff, 0x4015f4, 0x50e214, 520): stub

I tried user agent switching but it made no difference

Suggestions ?

Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Solved by:
Andrew Daviel
Last query:
Last reply:
Revision history for this message
Sebastian Lackner (slackner) said :

Hi Andrew,

first of all: sorry for all the circumstances, especially because there will be a much easier solution soon! ;-)

The "DarkPlayer" repository is maintained by Michael Müller, also a Pipelight pipelight developer, and will work out of the box after the next Pipelight update (which will hopefully be during this week). The reason why we left it in this non-working state is that some additional changes were required (mainly to make it possible to compile), which were introduced after the last official Pipelight release, so it will start working automatically soon.

Concerning your problem: It is either caused by

1) missing msttcorefonts - this is required for Silverlight, and if its not present, the area where the plugin should be is just empty. To fix this just install the package from DarkPlayers repo (I think it should be available there).

2) You said you used "--win32-prebuilt". This is okay, but you've to watch out, that you use two EXACTLY matching versions. If they don't match, you will not always get an error, but it will just not work. When you compiled the version of Pipelight, you should also use a prebuilt pluginloader.exe (from here: https://launchpad.net/pipelight/trunk/0.2/+download/pluginloader-prebuilt-v0.2.4.2.tar.xz ).

3) Run the browser with "PIPELIGHT_EMBED=0 firefox" (or any other browser). If it works then, but doesn't work embedded, then you're missing the 32 bit version of libXcomposite


Revision history for this message
Sebastian Lackner (slackner) said :

In the meantime there is an official repo for 64-bit CentOS packages.
See here for the installation instructions:

Revision history for this message
Andrew Daviel (andbew) said :

Thanks. Sorry about posting twice - I forgot where I'd been and used a different email address.

I restarted X and now Silverlight works. The instructions for installing the Microsoft web fonts are Debian-centric and it wasn't clear whether they were working. But I had tried removing them and the font used in the info box on right-click clearly changed, so I had assumed that was not the problem.

I had also tried installing Firefox in wine, which I was surprised to see worked (I have not tried wine for a long time; originally it would only run notepad and solitaire). I installed SIlverlight in that, but before I restarted X it was behaving the same as Pipelight.

I see there is now a Pipelight RPM in the Darkplayer repo so I will try that.

The Mediasite page worked, but Silverlight crashed a couple of times and there were some HTML issues - the slide index does not work in PiP mode and the controls in top right disappeared. If you are interested see e.g.