Netflix not working even though silverlight does on Fedora 20

Asked by bowser


On my Fedora 20 install Pipelight silverlight is working on both Firefox and Chrome. I have tested with the bubble test and However it doesn't work on Netflix. On Firefox there is only a blackbox while in Chrome there is an error saying cannot load the silverlight plugin.

Selinux has been dsiabled.

Not sure if It is a Fedora problem or Pipelight's Fedora build.


Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Sebastian Lackner (slackner) said :


I assume that you're using the same machine as in this earlier question:

when the bubble balls test and smooth streaming works, then its very likely a problem with GPU acceleration.

For testing purposes you can disable it by running:

then type "disable" and "abort". Afterwards restart the browser and try again.
If everything works then, please reenable it (same command, type "enable" and "abort") and create a log as described in my answer to your first question (and attach the log here).

By the way: If these are not two different machines, I would recommend to close one of the questions, otherwise its a bit confusing ;-)


Revision history for this message
bowser (bwbernard-wong1) said :


After "disable" and "abort" Netflix sort of worked, but trying to go fullscreen the screen went black (without actually full screen), sound is playing in the background though. This happened with both Chrome and Firefox. Also the browser was kind of frozen in that I couldn't kill it or minimize it (the netflix screen didn't get maximized, it just got black) and I could not switch workplace or brought up the terminal, so I had to kill the session with the power button. It is gnome shell 3.10.

Re enabled now and it is back to where it was before, Netflix doesn't load at all.

I may have misunderstood your instructions. I ran firefox &> pipelight.log and the log file is really short and kind of useless, instead of posting it to pastebin I may as well post it here:

 (process:3043): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

 (firefox:3043): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

The second line was repeated four times and then nothing.

Yes, this is the same installation as the one in my first question. It is a dual boot machine with Ubuntu (unity desktop) on the other partition. On Ubuntu everything works.

Thanks for the time.

Revision history for this message
bowser (bwbernard-wong1) said :

Oh sorry, I am so stupid, of course I misunderstood. It is 4 am in the morning. :) I have uploaded the log file .

Revision history for this message
bowser (bwbernard-wong1) said :

Opps forgot the link, here it is

Revision history for this message
bowser (bwbernard-wong1) said :


Got a bunch of errors when running /usr/share/pipelight/configure-silverlight, also put it on pastebin.

I noticed that there was no error like this when running /usr/share/pipelight/configure-flash so these may be relevant (as oppose to the long string of warnings as usual when running wine apps in the terminal)

Revision history for this message
Sebastian Lackner (slackner) said :

Well, its sufficient to take a look at the log to figure out whats going on:

err:winediag:xrandr12_init_modes Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your 32-bit OpenGL drivers haven't been installed correctly (using GL renderer "GeForce G105M/PCIe/SSE2", version "1.4 (2.1.2 NVIDIA 331.38)").

Please note that its really necessary to have the 32-bit drivers installed when you want to use GPU acceleration as we're always using the 32bit version of Silverlight.

How did you install the graphic card drivers? When you're installing them manually by running the proprietary *.run file, you have to select Yes when you're asked if you want to install the 32bit drivers. If its some kind of packaged driver you should check if there is also a 32bit version of it somewhere available.

The second log from configure-silverlight basically contains the same errors, I think they should also be gone after installing the 32bit drivers.


Revision history for this message
bowser (bwbernard-wong1) said :

The error "err:winediag:xrandr12_init_modes Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead." has been there for running any wine application with Nvidia driver for as long as I can remember and it never stops things from actually working,There was a bug report in Wine HQ but it was kind of ignored.

I got the same error in Ubuntu as well but pipelight works there perfectly so it could not be the reason.

I installed the driver through rpm fusion.

Can you help with this problem?

Provide an answer of your own, or ask bowser for more information if necessary.

To post a message you must log in.