Netflix Error N8156-6205

Asked by Michael Hans

Hey guys,

I am currently running ubuntu 12.04 (on a dual boot system with windows 7) and trying to get netflix to work using pipelight. I followed to instructions for installation with no errors occuring in the process. I enable silverlight and am able to use certain silverlight tests such as the bouncing bubbles ones perfectly. The problem occurs when I try to watch netflix. I first tried netflix using firefox. I installed the recommended user agent switcher "user agent overrider" and tried each of the user agents suggested. For each user agent I get the error code mentioned in the title. The screen shows the usual netflix load screen, but before it ever reaches 100%, the error message appears. I have also tried this in chromium, with various user agent switchers, and the exact same error message persists. While I can easily switch to windows through rebooting my computer, I much prefer ubuntu and would rather be able to open netflix without the hassle. Any help will be greatly appreciated.


Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Sebastian Lackner (slackner) said :


[ I assume you're using our ready-to-use packages including wine-compholio. If not (and you tried to compile it manually) then the reason could be related to a missing dependency during the build process. ]

It might be possible that you're using a filesystem without XATTR support. To check that please run:

sudo apt-get install attr

And afterwards, as a regular user:

touch ~/.xattr_test && setfattr -n 'user.testAttr' -v 'attribute value' ~/.xattr_test &> /dev/null; getfattr ~/.xattr_test 2>&1 | grep -q user.testAttr && echo 'It works!' || echo 'No workie!'; rm ~/.xattr_test &> /dev/null

If you get the message "No workie!" then you're either using a file system which doesn't support XATTR, or you have to manually enable it. I can give you some more instructions how to do this, please post the output of "mount" and the content of "/etc/fstab".

If you get the message "It works" then I would recommend to check, if you're really using our latest versions. To do this please run:

dpkg --list | grep "\(wine-.*-installer\|wine-compholio\|pipelight\)" | sed 's/ \+ /\t/g' | cut -f2-3;


Revision history for this message
Michael Hans (mhans13) said :

Thank you for your reply. I did use the ready-to-use package as instructed for ubuntu.

I ran the lines that you posted and I received the message "No workie!" The output of "mount" is below:

/dev/sda3 on / type ext2 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
gvfs-fuse-daemon on /home/mhans13/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=mhans13)

The folder "fstab" (mine says "fstab.d" if this makes a difference) has nothing in it.

Thanks again!

Revision history for this message
Sebastian Lackner (slackner) said :


its a bit unusual, but it seems that you don't have XATTR enabled, which should normally be the case.
Moreover you should have both the file "fstab" and a directory "fstab.d" - are you sure that you didn't miss it?

To enable XATTR you should try to add the option user_xattr to your /etc/fstab file (if it exists), if not I have also no clue where its stored then. Basically you have to open this file, and just have to append it for the specific device options, in your case the device /dev/sda3 which is mounted as /.

Here are some examples of what it should look like:

After you have added the flag, you can either just reboot, or even better use:
sudo mount / -o remount
to remount the partition without having to reboot.

You can use the same test as above to verify that XATTR is enabled afterwards.


Revision history for this message
jegpad (jane-padley) said :


Sorry to hijack, but I've got the same Netflix error and ran the commands as you suggested.
I get the following. Could you confirm if the packages are up to date please and advise accordingingly?
Many thanks
padjeg@padjeg-ThinkPad-L530:~$ sudo apt-get install attr
[sudo] password for padjeg:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 29.5 kB of archives.
After this operation, 143 kB of additional disk space will be used.
Get:1 saucy/main attr amd64 1:2.4.47-1 [29.5 kB]
Fetched 29.5 kB in 0s (310 kB/s)
Selecting previously unselected package attr.
(Reading database ... 232007 files and directories currently installed.)
Unpacking attr (from .../attr_1%3a2.4.47-1_amd64.deb) ...
Processing triggers for man-db ...
Setting up attr (1:2.4.47-1) ...
padjeg@padjeg-ThinkPad-L530:~$ touch ~/.xattr_test && setfattr -n 'user.testAttr' -v 'attribute value' ~/.xattr_test &> /dev/null; getfattr ~/.xattr_test 2>&1 | grep -q user.testAttr && echo 'It works!' || echo 'No workie!'; rm ~/.xattr_test &> /dev/null
It works!
padjeg@padjeg-ThinkPad-L530:~$ dpkg --list | grep "\(wine-.*-installer\|wine-compholio\|pipelight\)" | sed 's/ \+ /\t/g' | cut -f2-3;
wine-compholio 1.7.13~ubuntu13.10.1

Revision history for this message
Sebastian Lackner (slackner) said :

Hi jegpad,

there was a regression in wine-compholio1.7.13. You can either wait a bit and upgrade your packages again (fixed version is already on the build servers, but they are always so slow :( ), or if you want a direct solution, please take a look here:

The answer #4 lists URLs to the previous wine-compholio build. Just download the one matching your distribution (13.10) and install it with "sudo dpkg -i the_file_you_just_downloaded.deb".


Revision history for this message
jegpad (jane-padley) said :

Hi Sebastian,

Many thanks for your lightning fast response, much appreciated. I'll have a go.
And thanks to you and the FDS Team for such generous and comprehensive help on the Pipelight installation which I found here


Revision history for this message
jegpad (jane-padley) said :

Sebastian, Just an update - installed previous wine-compholio and set up user agent. All working tickety-boo. Thank you. Jane

Revision history for this message
Sebastian Lackner (slackner) said :

Why so complicated? This bug was fixed on the same day when the regression was introduced. In the meantime there is a new version 1.7.13-1 which also fixes this bug, so just updating again would have been sufficient - only 1.7.13 (without "-1") was affected. ;-)

Nevertheless I'm glad that its solved.

Can you help with this problem?

Provide an answer of your own, or ask Michael Hans for more information if necessary.

To post a message you must log in.