Unity3D asking for DirectX9.

Asked by Jonathan Ritchie

I was actually using Unity3D with good results. Do to some technical issues with my machine, I ended up doing a fresh install of Linux Mint 16; when I reinstalled pipelight-multi, and then enabled Unity3D, it was giving an error. To correct the issue, I purged Piplelight from my system; deleted pluginreg.dat and reset my firefox settings; deleted the .wine-pipelight folder, then reinstalled which got it to successfully enable unity3D once again.

Unfortunately, it is now loading the game, then says "Failed to initialize rendering. Make sure you have DirectX 9 and video card drivers installed."

I am currently using Pipelight-multi version

Question information

English Edit question
Pipelight Edit question
No assignee Edit question
Solved by:
Michael Müller
Last query:
Last reply:
Revision history for this message
Jonathan Ritchie (m-ricci-jon) said :

My question would be; is there a work around for this?

Revision history for this message
Jonathan Ritchie (m-ricci-jon) said :

Here is an output file for the firefox https://dl.dropboxusercontent.com/u/2139563/Unity3Doutput.txt

Also the game which is having issues would be located @ http://tinyurl.com/slotscentral (note: it requires a facebook account).

Revision history for this message
Sebastian Lackner (slackner) said :

Hi Jonathan,

it seems like you didn't properly install your drivers after the Linux Mint 16 reinstallation. As you can see in the last terminal output:

err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your 32-bit OpenGL drivers haven't been installed correctly (using GL renderer "Mesa DRI Intel(R) Ivybridge Desktop ", version "1.4 (3.0 Mesa 9.2.1)").

Can you provide some more details about which drivers you're using and how you installed them?
The following information could probably also help:

LIBGL_DEBUG=verbose firefox &> pipelight.log
glxinfo &> glxinfo.log


Revision history for this message
Best Michael Müller (mqchael) said :


can you check whether you have the 32 bit dri libgl module for Intel installed? You can install it with

sudo apt-get install libgl1-mesa-dri:i386


Revision history for this message
Jonathan Ritchie (m-ricci-jon) said :

Thanks Michael Müller, that solved my question.