"drm:i915_hangcheck_hung" using pipelight (yomvi.plus.es)

Asked by dmnmsc on 2013-10-27

Hi.

Watching streaming on plus.yomvi.es with pipelight freezes my desktop. systemctl returns me "[drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung", "look for more information in /sys/kernel/debug/dri/0/i915_error_state". You can see i915_error_state at https://dl.dropboxusercontent.com/u/2135959/i915.txt

I'm using Firefox and this happens with and without useragent. Moreover, my cpu temp using pipelight is 70-80ªC. I tried with "PIPELIGHT_FORCE_GPUACCELERATION=1" prefix, but still happening. I have an Intel HD Graphics 3000.

What do you think?

Question information

Language:
English Edit question
Status:
Open
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Last query:
2013-10-30
Last reply:
2013-10-27
Sebastian Lackner (slackner) said : #1

Hi,

which distribution are you using, and which version of pipelight? Does pipelight work as expected at the beginning (before it freezes)?

In some cases the pipelight log itself also contains useful output. To get it, just:
* close all browser windows
* Start your browser with: firefox &> ~/pipelight.log
* Upload pipelight.log from your home directory

It really sounds like its either a driver problem/bug or that your graphic card is overheating.
(You can also take a look at this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/946899 )

If your CPU enough you might try to workaround this issue by disabling GPU acceleration completely. The instructions how to do/test that depend on which version you're using exactly.

Sebastian

dmnmsc (jpujob) said : #2

Hi Sebastian. Thanks for your quick response.

My pipelight version is 0.2.0 and I'm using Chakra with 3.10.10 kernel. Pipelight works like a charm on Firefox, but always freeze my desktop (sometimes 30 min., sometimes 1 hour... who knows)

There's my pipelight.log after first desktop freezing: https://dl.dropboxusercontent.com/u/2135959/pipelight.log

Sebastian Lackner (slackner) said : #3

Hi,

unfortunately version 0.2.0 doesn't have a environment variable to disable HW acceleration, and as you have an Intel graphic card it will always as default. See this line in your debug output:

[PIPELIGHT:LIN:silverlight5.0] GPU driver check - Your driver is supported, hardware acceleration enabled.

(Beta packages for 0.2.1 which support the environment variable PIPELIGHT_GPUACCELERATION are only available for Ubuntu so far, but the official version will be pushed out in a few hours/days).

In case you're very impatient, you can use this FAQ to disable GPU acceleration:
https://answers.launchpad.net/pipelight/+faq/2364

(replace silverlight5.1 with silverlight5.0 in your case).

Does this solve the problem? Unfortunately I cannot guarantee that its still lag-free, that depends on your exakt PC configuration.

Sebastian

dmnmsc (jpujob) said : #4

Hi.

I tried disabling GPU acceleration following FAQ you suggested, but still freezing. My log is very short now: https://dl.dropboxusercontent.com/u/2135959/pipenogpu.log

Still freezing. I guess is because high CPU temp?

Sebastian Lackner (slackner) said : #5

Hi,

the log isn't really complete, either you forgot to capture stderr or didn't close all other browser windows first. Please try to create a new one, to ensure that GPU acceleration is really disabled.

Sebastian

dmnmsc (jpujob) said : #6

Hi,

Sorry about that, I forget the '&' on command. Now you can check it again and will see all output: https://dl.dropboxusercontent.com/u/2135959/pipenogpu.log

Seems like GPU acceleration isn't disabled. I give you my /usr/share/pipelight/pipelight-silverlight5.0 too: https://dl.dropboxusercontent.com/u/2135959/pipelight-silverlight5.0

Sebastian Lackner (slackner) said : #7

Hi,

well, the instructions were meant such that you only modify ~/.config/pipelight-silverlight5.0 (the user-specific configuration) and not the global one (which is okay too, but will be resetted on each pipelight update). A user-specific config is always preferred over a global config.

In your case you have created a local config without modifications, and a global one with modifications (which has no effect, as the local one is preferred).

The easiest way to fix it from your current situation would be to delete the local config:

rm ~/.config/pipelight-silverlight5.0

such that there is only a global config with the appropriate changes, or alternatively:

# restore the global configs
sudo apt-get install --reinstall pipelight-multi

cp /usr/share/pipelight/pipelight-silverlight5.0 ~/.config/
gedit ~/.config/pipelight-silverlight5.0

and do the change there again, uncomment the following line:
overwriteArg = enableGPUAcceleration=false

Sebastian

dmnmsc (jpujob) said : #8

Hi Sebastian,

Seems like new config (no GPU acceleration) is working fine. Anyway, I need to test this in a hard way. My previous hangcheck_hung were watching football. So, next time I watch it, I'll check. Now I only can do little checks with common tvshows (more static images and less speed movement than football game) but seems my CPU temps is lower and no freezes.

Please don't close or mark it as solved since I didn't tested yet. I'm just posting this to tell you I'm not dead and I have not forgotten you.

Here you can see my new log:
https://dl.dropboxusercontent.com/u/2135959/pipenew.log

Thanks for your help! I'll post again when my hard test comes true.

dmnmsc (jpujob) said : #9

Hi again!

100 minutes watched and no problems so far. Everything worked fine. Should I mark this as solved? I never experienced drm:i915_hangcheck_hung/freeze before pipelight and never experienced hangcheck/freeze with other apps/services using HW acceleration (even with pipelight installed).

If you think this is distro/drivers related (and not a pipelight problem), then I'll mark this as solved.

This is my new log: https://dl.dropboxusercontent.com/u/2135959/pipefootball.log

Let me say... Thank you for all your support! Now Yomvi works like a charm. I don't have HW acceleration but temp is cooler and everything goes smoothly.

Can you help with this problem?

Provide an answer of your own, or ask dmnmsc for more information if necessary.

To post a message you must log in.