trying to watch netflix or other silverlight content creates alsa underruns

Asked by akaper on 2013-09-24

I installed pipelight following these instructions:
https://forums.opensuse.org/content/174-silverlight-opensuse-howto.html.

My desktop is an openSUSE 12.3, KDE 4.11 and kernel 3.10.10.
Winecfg sound is set to: Out: HD-Audio Generic - ALC889 Analog
Hardware: AMD A6-3650 APU with Radeon HD Graphics.

I tried several browsers (firefox, chrome, chromium) with the proper user agents and get buggy video and buggy sound.
Here is the output when I start chromium to open www.netflix.nl in the terminal:
http://susepaste.org/17056998
Firefox and chrome show the same thing: alsa underruns.

Tweaking the pipelight conf file makes no difference at all, using these procedure:
https://answers.launchpad.net/pipelight/+faq/2356
In fact, none of the FAQ options seem to do anything with the underruns.

I used the same installation procedure on my HP compaq 6710b and there everything works as to be expected: I can watch Netflix without any problem, out of the box.

What can I do to resolve this?

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Solved by:
akaper
Solved:
2013-09-25
Last query:
2013-09-25
Last reply:
Michael Müller (mqchael) said : #1

Hello akaper,

this problem can have a lot of different causes. Since your sound card most probably does not support multiple hardware streams, you are using some kind of software mixer like Pulseaudio and I think the problem is somewhere in the communication of Wine <-> Pulseaudio <-> Alsa. Can you try to restart Pulseaudio before testing by executing pulseaudio -k and check if this changes something? If you are using a software mixer it may also be better to set the audio device to the system default device since the Wine version you are using does only support Alsa and not Pulseaudio directly. If you change the output device in Wine to something else it may be possible that not the virtual Alsa device of Pulseaudio is used but some fallback mixer of Alsa.

Michael

akaper (laatvlieger123) said : #2

Thnx for your response.

Wine sound settings are back to system default (env WINEPREFIX=~/.pipelight winecfg). But this changed nothing.
Then I tried out your next suggestion by firsts restarting Pulseaudio: This also changed nothing.

Also I tried the following:
- fall back on the standard wine packages in the oss repository and thus removing wine-pipelight. After that I reinstalled wine-pipelight form the pipelight repo. To no avail.
- creating a new user account and a fresh ~/.wine and ~/.pipelight prefix
- even compiling wine-compholio and pipelight, roughly following the instructions on this website and these instructions: http://pastebin.com/uZiHKDqe

Since all this didn't help, I think you're right. I can try to temporarily disable Pulseaudio in Yast to see if that accomplish anything. Do you have another suggestion?

Sebastian Lackner (slackner) said : #3

Did you manually change the wine-prefix directory? The default one is ~/.wine-pipelight, NOT ~/.pipelight (except you're using some packages, that have these changes included). A wrong wine prefix in one of the commands (like winecfg) doesn't lead to an error, but instead just creates an empty one, so it might be possible that all changes you've done didn't have any effect because they were in the wrong prefix.

If this is not the case: Unfortunately I also don't have any idea why it doesn't work :/ Are you using some outdated audio packages or something else unusual? Does the "Test sound" button in winecfg work? Do you have some other wine applications with sound, and if yes, do they work?

akaper (laatvlieger123) said : #4

Sebastian, you're right: that was a typo. I installed with the default options, so the wine prefix is ~/.wine-pipelight.

You're remarks got me thinking: I think I solved it.
I searched for a way to get Pulseaudio out of the way for wine. After some googling, I found that winetricks can do that. I performed the following steps in a terminal:

env WINEPREFIX=~/.wine-pipelight winetricks

and after that in the winetricks window
"Select the default wineprefix"
"change settings"
"sound=alsa"

I still had the problem that wincfg produced no test sound in the Sound Tab, but simply crashes on me.
I resolved this like this:
env WINEPREFIX=~/.wine-pipelight winecfg
Sound Tab
Then I fiddled with the options available, ending up with: Out: HD-Audio-Audio Generic - ALC889 Analog
Only this "driver" produced finally the beep sound, clicking on Soundtest button. Before the trick with winetricks this didn't work.

After all this I have good sound and thus good video on netflix in Chrome, Chromium and firefox. No Alsa underruns anymore!
Hip hip...

Sadly, this did not work for me at all. Still have random fast video and no or garbled sound.