No config file found...

Asked by Mark Berthelemy on 2009-10-06

Hi there,

I've got PHPDevShell installed on localhost, on Windows XP. PHP & MySQL working fine, as I run a dozen other applications from inside localhost.

PHPDevShell is located inside a sub-directory of localhost: http://localhost/phpdevshell

.htaccess is not yet switched on.

I can run the install.php script, and can login to the application backend.

As soon as I try to go to the front page, or direct to http://localhost/phpdevshell all I get is:

No config file found for host "localhost" inside folder "C:\Documents and Settings\mark.berthelemy\My Documents\websites\phpdevshell\config/
Read the install instruction on creating a config file and installing the database.

Any ideas what I've done wrong?



Question information

English Edit question
PHPDevShell Edit question
No assignee Edit question
Last query:
Last reply:
TitanKing (titan-phpdevshell) said : #1


Did you rename both your config files removing the ".new"? The directory seems very odd where it is actually looking for the config file.

Could you also post the content of your host.config.php?


Hi there,
Here's the directory listing of the config directory:

 Directory of C:\Documents and Settings\mark.berthelemy\My

06/10/2009 10:22 6,206 default.config.php
08/08/2009 10:04 1,351 host.config.php
08/08/2009 10:04 653 index.php

The host.config.php file looks like this (I've not changed it at all):

 * PHPDevShell is a RAD Framework aimed at developing administrative
 * @package PHPDevShell
 * @link
 * @copyright Copyright (C) 2007 Jason Schoeman, All rights reserved.
 * @license GNU/LGPL, see readme/licensed_under_lgpl or
 * @author Jason Schoeman, Contact: titan [at] phpdevshell [dot] org.
 * Copyright notice: See readme/notice
 * By using PHPDevShell you agree to notice and license, if you dont agree
to this notice/license you are not allowed to use PHPDevShell.

// Setting hosts, allowing multiple installations from one directory. //

 * Allows multiple sites to be installed from one core directory.
 * Setup as $configuration['host'][[host/domain]] = [config file prefix
[default]].config.php]; (Multiple)
 * @global string $configuration['host']
 * @author Jason Schoeman
$configuration['host'][$_SERVER['SERVER_NAME']] = 'default';
//$configuration['host'][''] = 'default';
//$configuration['host']['localhost'] = 'default';
//$configuration['host'][''] = 'default';




TitanKing (titan-phpdevshell) said : #3


Why is the files in your "My Documents" folders? Try hosting them directly from your hosting folder. Are you running a service like XAMPP, you are you are running Apache 2 right?

Hi Jason,
That websites folder *is* my hosting folder. It's the localhost
document_root directory.

Yes, I'm running Xampp with Apache/2.2.11



TitanKing (titan-phpdevshell) said : #5

Hi Mark,

We are going to try and replicate the error on a Windows Machine, perhaps this is a bug on Windows machines.

Will give you feedback as soon as we get this far. We have noted a / slash in the end of the config, I believe this might be the problem.


Greg (gregfr) said : #6

I'd say the message is self-explanatory: you don't have a config file for the host named "localhost". That means PHPDevShell is looking for a file named "localhost.config.php" in the config config folder. I'll try to figure out why, but meanwhile you'll probably be ok by making a copy of "default.config.php" named "localhost.config.php".


Thanks Greg,
I've just tried adding a localhost.config.php file, but it made no

However, what *has* made a difference is switching browser. I use Firefox
for all my development work. That's where I was seeing the problem.

In Chrome however, the same url (http://localhost/configmanager/) takes me
to the ReadMe page.

So, it's not the app. It's the browser. Very odd.



TitanKing (titan-phpdevshell) said : #8

Very odd... remember in Windows .htaccess does not work, so dont switch on Friendly URL's in the config. This is the only thing I can think causes this behaviour.

Greg (gregfr) said : #9

After some research, I'd say the trailing slash is problematic. I'm working on a fix right now.

What is this url "/configmanager"? In firefox, did you try "http://localhost/phpdevshell/" (note the trailing slash) instead of "http://localhost/phpdevshell" ?


Hi Greg, Jason,
All seems to be fixed now. I've cleared the Firefox cache and it works OK,
even with the trailing slash.

I think it must have been because I went to the install.php file before I
set up the config.php file. (That's just based on experience with other

Sorry for wasting your time.

BTW. Jason, friendly URLs do work in Windows, just as long as you're running

Thanks for all your help both of you.


Greg (gregfr) said : #11

I made some changes on the BZR repos. I would be nice if you could test it on your windows machine, as we are all working on linux servers.

Hi Greg,
Sorry, you'll have to explain what you mean by BZR repos? Do you mean on the
Download file?


On Tue, Oct 6, 2009 at 3:55 PM, Greg <email address hidden>wrote:

> Your question #84954 on PHPDevShell changed:
> Status: Open => Answered
> Greg proposed the following answer:
> I made some changes on the BZR repos. I would be nice if you could test
> it on your windows machine, as we are all working on linux servers.
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> You received this question notification because you are a direct
> subscriber of the question.

Greg (gregfr) said : #13

Hum I don't see any easy way to download a development state. Jason do you know any?

Can you help with this problem?

Provide an answer of your own, or ask Mark Berthelemy for more information if necessary.

To post a message you must log in.